PowerCore Speed 20000 not charging

hi I bought the PowerCore Speed 20000 over a year ago and for some reason it stopped charging.
i am using the PowerPort to charge it and it seems that my pd port in the power bank is not responding.
it seems the pd port is not giving charge nor taking any charge.(i tried switching the cables and nothing is working)
if someone could help me i would really appreciate it.

As far I see you have tried different cables, but have you done a reset?

For a reset connect the in- and the output with the added cable for 10 seconds.
If you charge it after that procedure : DO NOT press ANY buttons.

You may also a look in the socket with a magnifier is if there is any debris or something bent.

i tried to look and i cant see any bent pins or any debris that might cause an interference with charging.
as i do the reset is something supposed to happen? it looks like its not responding to any device i connect to the pd port.

If you have tried all this you should call the support, which has more efficiency than write an email.
You will find the phone number for different countries here at the web site.
Good luck!

where can i find how to contact them?
and thank you for your time trying to help me


We always do our best here to help! :smiley:

1 Like