Powercore Slim 10000 Question

I just purchased the Powercore Slim 10000. I’ve charged it. When I go to charge my iPhone 11 Pro I never see the charging indicator come on. Is that normal or does that indicate it’s not charging?

1 Like

If you charged your powerbank, you should see 4 blue LED right up on the button when you press it once. I’m assuming you should be able to plug a cable in and it would charge your phone right away. If it doesn’t, have you tried to press the button once to see if it starts charging your phone? Also try using a different cable to see if it helps

1 Like

Just to verify: are you charging from the larger USB-A port? The other two smaller ports (Micro USB and USB-C) are input only, so they will not charge your iPhone.

3 Likes

I haven’t tried all the options but I believe that the order makes a difference. Last night I inserted the USB cable first, then pressed the button, then inserted it into the phone and immediately got the charging symbols and it fully charged the phone. I believe the order might have been different before and I also noticed that it didn’t take very long for the lights on the button to go out so if you get distracted you plugging it into the phone with the button off. Bottom line it’s now working just as I expected. My phone was about 40% charged and I was pleased that the Powercore still showed 4 lights when the phone was fully charged. Thanks for the replies.

1 Like

You should just be able to plug it in and it will charge I’m pretty sure both devices are pd capable