PowerCore+ Quick Charge Recharge

So I want to see if anyone has experienced this, or if I am some weird fluke.

I have a PowerCore+ 13400 and a PowerPort 2 with QC3.0.
Anytime I tried to use the Quick Charge port to recharge the PowerCore+, the PowerCore would just constantly reset.
It would never charge. Charged fine off of the PowerIQ port.

So I went through a process of elimination.
I bought another PowerPort, same result.
Tried a different cable (that I thought was high quality), same result.
Contacted support and after some conversations that frustratingly went nowhere, they just said that it must be bad, exchange it.

After the replacement came in, same issue.

Finally, I tried an armada of cables that I had around the house and found out that it was a cable issue.
Which totally blew my mind that the stock cable that came with 2 different units would not quick charge the device.

I am a huge Anker fanboy, but starting to doubt the cables.
Has anyone else experienced issues getting their PowerCore+ devices to Quick Charge?

In the end I bought a cable that specifically said it was compatible with Quick Charge as my solution.
I’m still in shock that the stock cable didn’t quick charge.

That’s good information to have. We just bought 10 of the quick charge Powercore+ 26800 and will now make sure to test them all before we get them out in the field.

1 Like