Powercore II 20k won't charge with 1A

I have a Powercore II 20,000 that I thought was defective this week. The first time, I charged it with a 1A wall charger and it was complete in maybe 20 hours or so. No problems.

The second time I tried again with a 1A Apple charger and the lights would blink for a few minutes to indicate charging, but then the lights stopped. (I have confirmed the Apple charger is working because I continue to use it every night to charge my phone)

A few days later, I used two 2.4A chargers and now the Powercore successfully charged.

Is there some issues with 1A charging?

I would highly discourage a single 1A charge. Are you using both ports? It accepts charge to 4A, so I would recommend a dual 2A charger, such as this one (2.4A).

You might want to update your link to one like this :wink:


Original is going to the Soundcore 2 page

Whoops! Updated to the Elite.

1 Like

Same port, different port on second charge attempt? I don’t have the PowerCore II model but can’t say I’ve had issue’s on a single port charge on my older gen PowerCore (apart from it taking longer).

As @joshuad11 has mentioned though it is advisable to invest in a dual-USB charger for a PowerCore like this…

1 Like

I tried both ports and tried different cables.

It was weird that it worked a first time with a 1A charger, but it didn’t work with my 1A Apple charger. (both of these 1A chargers function properly & are still in use today)

I ordered a new Anker 2 port Elite charger, so I will use that for my 3rd charge and see how that works.


If it doesn’t, I’m sure @AnkerOfficial will hook you up with a new one. Just shoot them an email.

Could be the 1A Apple charger doesn’t provide a stable enough voltage output to ‘reliably’ charge the PowerCore.

1 Like