PowerCore II 20000 double charge rate, really?

When I use a single input, I see a 2 Amp charge rate. When I plug in the second input, both inputs drop down to 1.4 Amps. So the charge rate goes from 2 A to 2.8 A. Hardly double. What gives?

I’m using the Anker supplied charge cables. Battery is at 50% SOC.

1 Like

What charger are you using?

That’s not promising. As @Tank said which charger are you using?
You will need somthing like Powerport Elite 2

I was using 2 ports of the Anker 40W 5 port charger. 3 ports unused. I moved one of the charge inputs to a separate wall charger and then both charge inputs were at 2 A! So the issue isn’t the Power Core, but rather the Anker 40W charger.

In that case give this a try for the 5 port charger: If a port isn’t working properly, it may be because your device has triggered the protective internal safety switch. In order to reset the switch, unplug all cables (including power cable) for five seconds and retry.

1 Like

Just tried Tank’s suggestion (thank you) but no change. I’ve tried different port combinations on the 40W charge. I should probably start a new thread on the 40W charger.

Your charger is capable to provide 2.4A per port(total of 8A).
Do you have another set of cables to try?

How empty is the Powercore when you measure? It needs to be nearly empty to be able to ingest faster.


I think OP measured it at 50% SoC. It should be absorbing max current at 50%. Current only drops at over 85% SoC
(*SoC = State of Charge)