PowerCore+ 26800 will not charge over 6 dots. Had it connected to output for over 30h

First I would like to thank you for your great products. I’ve had the Powercore+ 26800 for about one year now and until two days ago it worked perfectly.

However, for some reason it won’t charge over 6 dots. I’ve had it charging for over 30h but it just comes up to 6 dots and then continiue to charge without progressing. Is it faulty or is there something I can do to fix this?

Thank you,

Hi Chris, would you please let us know what kind of charger you are using? If you have one available, it wouldn’t hurt to try a different charger and a different charging cable just so we can rule them out. Ideally, you’ll want to use one of Anker’s wall chargers or another USB charger that can output 5V 2A (which you can usually find by looking at the small print on the charger).

Hi and thank you for your answer.

I am using a 5V 2A Samsung charger. The cable is the one i got with the powercore.

You could also try plugging the power bank into itself to reset it.

I did that but nothing happened. How long does it need to be connected like that to reset?

i had to use a different, heavier/thicker cable to charge mine. it sounds ridiculous, you probably think I’m stupid so you wont try it maybe. I don’t know why, mine just seems picky. But it worked for me

It should only take a moment, but you have to make sure to forcefully turn it on while it is connected if it does not do so itself.

Thing is that i have used the same cable for a year and it used to work untill now. Also it charges the pack up to 6 dots and then indicates charging but never goes over 6 dots.

Hi @Chris_Tian,

From your description, the Powerbank is seems defective, please contact support@anker.com, we will ship a replacement.

1 Like