Powercore + 26800 PD not charging

I bought 2 units of powercore + pd26800 along with the charging brick. The first units works perfectly out of the box, the second unit refused to charge at all. It’s been plugged in for 6hrs+ no indicator at all. Please help.

I can’t return these now because my cousins help me bring this items from the US

Sorry to hear.

When you say one works one doesn’t, is the same cable being used? The most common cause of issues are cables.

You can try to reset the failed unit. Connect it to itself, connect its input and output ports and press the power button.


I tried my MacBook charger, it doesn’t charge the powerbank. If I press the power button while charging, it flashed a white light. But when not plugged in, pressing the power button gives no feedback whatsoever.

I tried the looping thing too. No luck yet.

Thanks for responding though.

It does seem that the power bank might be defective. Please contact the support folks at support@anker.com to see if warranty service is available in your location.