PowerCore+26800 PD not charging properly or has issue with the LED

Hi everyone. I just bought a PowerCore+ 26800 PD and a PowerPort ll wall charger with PD as in my country I have to buy them separately.

The first thing I did was to charge the powerbank using the wall charger and the USB C-C cable provided by the powerbank. The initial powerbank provided me with 3 LED lights. So I went to charge overnight. The next morning, the powerbank was still charging so I figured the cable might be the problem as it was supposed to be fully charged by then. I unplugged it and it showed only 2 LED lights. It went down from 3 to 2 LED lights.

I did a second try by using another cable (USB C-C cable from Pixel 3 charging cable) to charge my powerbank using the same wall charger I bought. A separate issue occurred. This time, the powerbank was charging fine for less than 5 minutes then the LED wheel shut off. Meaning it was not charging.

I did a reset on the powerbank by looping a USB A-C on the powerbank. I had to try it again. This time, it was charging for some time. When I got back from outside, the LED wheel was not lit so I assumed the powerbank was fully charged. I was out for about half a day so the powerbank should be fully charged by then. I unplugged the powerbank and pressed the LED power button. It was all lit up (100%) but after awhile it went down to 3 LED lights when I decided to confirm it had been fully charged.

I had emailed the customer support and am waiting for their response.

What could be the issue here?

Should be a defective item.
You tried all the steps which we would recommend to do as far I see.

What wall charger dis you buy? Also did you plug it in when all the lights where off? Because it has power both ways if younoress the button and then plug it in it will show the lights as you mentioned, but it will turn off after a little bit because it’s trying to output power instead of taking it in.

This is the charger that I bought.

Yes I waited for the LED wheel to be off before switching on the wall socket power.

It’s a high possibility. But I can still charge my device though.

Hmm have you tried a usb c to a cable to charge it? Instead of the c to c cable

Missed that part in my initial post. Yes I had tried it as well but it gave the same result.

That power bank NEEDS dual input to charge or will take a couple of days.

It takes ages with 2 microusb inputs, but one will take lit twice as long.

The issue with my powerbank is not the speed of the charging. It is whether my powerbank is charging or not as I am unable to determine due to the LED wheel not flashing consistently to indicate that it is charging.

Are you using the lead n charger that came with it?

Check also the terminal on the power bank. If you’ve ever knocked it with the lead in, it’s easy to damage the terminal… Have a look with a torch and magnifier/glasses.

Otherwise, bar changing lead n wall charger, as others have said contact support.