PowerCore+ 26800 PD not charging Macbook

Upon removing the PowerCore from its packaging yesterday I tested it on the Macbook Air and it indicated that it was charging.

I charged the PowerCore overnight with the charger included and now it will not activate when plugged in to the Macbook.

I can charge a phone using USB-C to USB-C but can not get the Macbook to charge. I press the power button and then plug into the Macbook and shortly after the PowerCore lights go off. Yesterday i didn’t even have to hit the power button. I just plugged it in and and PowerCore activated.

Is it worth buying a USB-C to USB-A cable to try the reset? Has anyone else had this problem?

I have contacted customer support and started a case, they have not wrote me back yet so I thought I’d ask the community.


Have you tried using a different cable? Or even reversing the cable? With that pack your suppose to press the button in order to output a charge, since before you didn’t press the button the pack could have tried to draw a charge from your mac giving you a false charging reading