Powercore 26800 issue

Family came to visit this weekend and had planned to go out on day trip, so decided to get the powerbanks sorted in advance. Plugged my powercore 26800 into charge Thursday evening, checked it Friday morning and it was still flashing 1 light. I have tried other leads and plugs (although first plug is working well and charging other devices) also tried resetting it by plugging cables from output into each output - 1 at a time and also 2 at the same time.

Was my method of resetting it correct?

Just wanna check for advice here before seeking advice from the support team


What kind of plug are you using to charge this? At a minimum you should be using a charger that can supply at least 5v 2a. Also if the battery was drained fully and not charged for a bit it can generally take longer for it to start charging properly. But realistically it comes down to the cable or wall plug


Using these as I bought a couple of last year …

Plus using anker cables - I have a small collection and tried brand new ones.

It wasn’t fully drained when I started to charge it. Maybe I will drain it completely and try again for longer

which 26800 battery pack do you have? One has dual input, two of them use Quick charge 3.0 and the other is power delivery. so depending on which one you use will dictate how it charges. The charger you posted supplies around 2A so it would take a bit of time to fully charge your battery pack if its of the quick charge type or power delivery. 1 thing to note is that even though the cable may have come with Anker products, I have found that they don’t always allow fast charging…its a free cable so generally of the lower variety and not the top of the line that can sustain higher currents for fast charging.

It has dual inputs.

That’s why I wasn’t sure on the resetting procedure and tried a couple of different way lol

The specs say 6 hours, can’t remember exactly how long it normally takes as it cuts off once fully charged - normally charge overnight and it’s good to go

ok then yea it should charge within 6 to 8 hours given the dual input. i would try using different cable as i mentioned above some may not be sufficient to properly charge this.

Yeah I’ve 2 brand new ones in at the min.
If no luck will fully drain it first and try again.

Just wanted to see if I was resetting it properly.

I am having the same problem with the Powercore Lite 2000. I just received it, it was half charged, and it has been charging for 24 hrs now, and only two leds blinking since I plugged it in. Do not know what to do.

Something is wrong (obviously): 1 power bank dead, cable went bad or wall charger went bad. I’m leaning towards the power bank on this one. I have another power bank that wouldn’t charge and the charging resistance is through the roof. “Charges” at 0.35A

Yeah. I’m going to call customer service tomorrow.

Try and unplug your battery pack, wait for the lights to go off and then press the power button. see how many lights light up then. Also you can try to reset the battery pack by plugging the power cable to the input to charge the battery pack and take the other end and stick it into the usb output port

wow. It looks like the reset did it. it is charging now. thanks

There you go, glad it’s working for you now

@elmo41683 Does the reset actually reset a circuit on the battery? I’m curious if my batteries ever fail…

There are a number of safety features on these battery packs to prevent damage, to the internal batteries and devices being charged. It can trip for a faulty cable, a shock, any number if things so it it was able to reset and didn’t retrip then you should be good to go. It resets the internal safety mechanisms.

1 Like