PowerCore+ 26800 charge status only 1 light

My Powercore+ seems to charge, the ring of lights continually lights up when charging, but when I unplug it to check the current charge status, only 1 light blinks. I’ve had it charging for a couple hours now, and I have tried different cables, and power bricks.

When I plug a device into it to receive power it appear to have some charge. Any thoughts? I am unfortunately outside of the warranty period.

1 Like

Hi @Mitchell_Holt
Such a shame you’re having issues out of warranty.
I guess it was charging ok before so you could try a reset.
I believe this can be done by looping the charging input and the output with an appropriate cable for 5 second and give it another try.

Also, if you have a copy of your receipt make contact with support including a photo/screen grab of the receipt and get them to review for you. support@anker.com

Keep us up to date with your progress.

1 Like

Such a big Powercore will probably take a lot of hours to charge. It’s best to let it charge overnight and check it I’m the morning :+1:

First to set expectations, based on your words, it appears a failed unit outside of warranty.

But. Let’s try any ideas.

Let’s be precise on exactly which model. Plenty of Anker products have very similar names. Get a magnifying glass to the base and confirm model code.

https://www.anker.com/products/variant/powercore--26800/A1374011

Are you seeing A1374?

If so, one possibility is your actual charger has failed, and your are not using another QC 3 charger, so making it recharge slowly as in

Email support@anker.com

In a positive tone, they may give you a discount code off new as a goodwill gesture, even if outside of warranty, so long as you show reasonable efforts to look after it and you tried plenty yourself to fix.

1 Like

Hello Everyone,

Thank you for the responses and suggestions. While looking through the forums I found a post where someone had sort of the opposite problem, the lights wouldn’t show when it should have been charging, and they ended up fixing it by completely draining the battery. So I plugged as many devices into it as I could to try that and it appears to have worked.

After it was out of battery I plugged it back in and checked it this morning and all the lights are working.

Thank you.

1 Like

Nice one @Mitchell_Holt thats great news.