PowerCore 26800 can not be charged or is it the leds?

Hi Everyone,

This is my first Anker device and I think I am having problems. I wanted to charge the device itself with the cables those came with it. I have been patient, and I have been leaving it to charge for at least 10 hours trying different cables and adapters.

  • tried iPad 2 charger
  • tried wall usb socket 5v 2amps

tried 3 different cables.

I have tried emptying the battery till its dead completely and recharging it.

4 led indicators on the device, never seen 3rd and 4th one lighting up or blinking

when I disconnect it and reconnect it 2 leds light up and they go off after 20 mins or so. I left it for 24 hours still nothing more than 2 lights.

Any suggestions ?

You need to make sure not to push any buttons when you go to charge the battery pack. Otherwise it will try to output power instead of charge itself


Thanks for the advise @Tank

Unfortunately that is not the case.

Where did you purchase? Can yo uexchange the item? maybe you got a defective one.

I sent the device back to amazon. Thanks everyone…

2 Amp was not enough for mine, when I put it on a 6.5 amp, it charged fine,