PowerCore 20100 PD dead!

I haver a PowerCore 20100 PD about 2 months.

Yesterday the battery just died.

No signals whit power connection. I’m using a original Anker PowerPort PD30 + Anker Original Cable (usb-c / usb-c).

I tried With another anker cable (usb-c > usb) but I Aldo had no signal.

Any tips ir help?

I tried to reset de battery. Insucessfully.


Maybe the outlet you plugged it into is bad? Try another outlet

Try a different outlet, if that doesn’t work and it’s still under warranty, I’d recommend sending Anker support an email

Have you checked the ports to see if there’s dust in it that would give it a bad connection? If that doesn’t work email them at support@anker.com .

Try a couple of things
First try to use a different wall plug as that could be faulty
Second try to use a different cable other than what u have tried.
Third try plugging the USB a end into the batterypack and take the USB c end and plug it into the USB c port on the pack, thus creating a loop into itself… Leave it for 7 to 10 seconds and this will reset any internal faults that may have been tripped


Hi, Folks

I tried all your tips. No sucess.


You only option is to reach out and send support@anker.com an email explaining what’s going on. Let them know what you have tried already, they will ask for the serial number and your original order number as well as any steps you have taken to try and remedy this

1 Like