PowerCore 20100 NOT WORKING

My PowerCore 20100 is fully charged but when i press the side button the lights come on for one second and then shutoff. It does not ouput a charge to any of my devices. I have tried multiple different cables. Has anyone else had a similar problem? Any quick fixes? Or do i need to exchange it as it is still under warranty.

1 Like

If you’ve tried multiple cables and no connected devices are pulling a charge, it sounds like the warranty route.


Is that the same on both ports? Just wondered if it’s totally broke or half broke :wink:

You’ll still get a replacement either way but it might still work a bit.

1 Like

I would try to charge it using a different cable and plug, only leave it plugged in overnight for at least 8 hours to see if anything changes.

1 Like

Do you have access to a digital multimeter by chance? You can check the pins for an output since they should activate once a load is applied (load is the meyer in that instance)

Thanks everyone. Nothing seems to work. Anker support got back to me quickly and said i will receive a replacement in 3-4 days.

1 Like

Glad to hear that, I was just about to inform the support team. Hope you’d like the replacement. :grin:

1 Like

You should contact … oh wait Anker are already sending you out a replacement.

That’s why Anker customer support is one of the best I’ve ever come across. :raised_hands:t2:


Thank you for letting us know your concern! We are terribly sorry about the unique problems you’ve been experiencing with our products. If you need any help, please sent an email to support@anker.com. Our support team will try the best to resolve the issue for you.

Meanwhile, we do take our quality control very seriously with numerous and rigorous checks in place. We will forward the details of the case straight to our quality control team so they can be made aware of the situation.

I have the exact same problem as described in the main question, but my device is a PowerCore Lite 10000. Anker has sent me a replacement, but still I wonder if I can somehow revive the old device, because it seems like such a shame to just dispose of it. Do any of you have any tips?