Powercore 20100 not charging

Last night I charged my powerbank (powercore 20100 mah) and the led lights were blinking properly, when I woke up after more than 6hrs there were no blinking lights so I removed it from the charger thinking it was fully charged.

But after 2days I tried to turn it on but the lights wont come. Then I tried charging again but still no light will come. I left it plugged for about 5minutes then I unplugged it and turned it on and there was a blinking light so I plugged it again but the light stayed solid.

Any help please? I just newly bought it.

Try a different cable. Try a different charger. What might have happened is the cable was on its way out and just managed to get a trickle charge through the cable before the cable then failed completely.

However the fact it did show signs of charging and then no probably looks like a dud Powercore.

After trying different cable, different charger, if still not working then email support@anker.com with your order details, serial number and evidence it doesnt work and you tried different cable and charger, and I’m sure they’ll put you right.


Hi @Ruri_Zoldyck, as @nigelhealy said, try different cables and chargers, if still not working, you may receive a defective product. Please be assured that we offer 18 months warranty(replace or refund) and lifetime technical support. If the test results not good, could you please contact us Anker at "support@anker.com" ? We are glad to help you!:innocent:

This happened to me. It was the micro usb cable. Change it over, bang it back on change and away you go :ok_hand:


I don’t know that’s a touch situation hopefully it works again.

I now have the same problem. I’ve tried different cords, with no luck.

When I plug it in to charge, it shows 4 lights lit solid and then the other go like it’s charging. But I leave it plugged in over night. I unplug it and plug into my iPhone and it doesn’t power on. I’ve tried the reset suggestion and still nothing.

Of course I purchased it in September of 2017 from Amazon, so it’s just out of Warranty.