Powercore 20100 not charging. Help!

In June 2019, I purchased the Anker Powercore 20100 Nintendo Switch Edition from Argos UK. It had been working really well until today. If I remember correctly, when it runs out of charge and I plug it using the switch wall charger, it should start blinking or at least lighting up to let me know that it’s charging okay.

However, today when I have plugged it in, it wasn’t blinking. No lights at all. I tried a different cable using a different charging port and it’s still not indicating that it’s charging. I also tried pushing the button while it’s plugged in and the lights blinked on and off a couple of times which I took as an indication that it’s low on charge but it went back to being dead again even while plugged.

Right now I left it plugged and charging even though the lights are off. I already sent an email to Anker Support. Just wanna know if there are any other solutions I can try while waiting for their response. Thanks!

You can try a reset.
connecting input and output socket via cable.
There are more instructions here , you will find them.

Try different cable

Try different charger


Anker tends to work Chinese hours, they’ll be awake and reply probably in about 12 hours from now.

1 Like

As already suggested while you are awaiting a response to email, a reset attempt would be a good test to try and kick back to life…

1 Like