PowerCore 20100 (A1271) suddenly dead

I received the PowerCore as a gift last year and it worked just fine until today
The LEDs do not come on while trying to charge the PowerCore or while trying to charge a phone.
Looking around the forum I tried a number of things

  1. Letting it rest for a few hours then pressing the button => No success
  2. Pressing and holding button while plugging in to charge it => No Success
  3. Replacing USB cables => No success
  4. Trying to charge small devices (like Samsung earbuds which draw a very low current) => No success

The device is not very old (I am guessing six Months but it was a gift so can vary)
The charge was holding perfectly until today so no weakness in the cells.
The PowerCore was inside at room temperature so no environmental factors are plausible.
As it is a IQ device it has curcuitry which could have gone wrong.
Is there some sort of reset process?
Does anyone have any recommendations what to do next?

Sorry you are having issues, we can try to help best we can here. Can you Try using a different wall socket, I know you said you tried different usb cable but give it a go with a different wall socket and cable…only this time leave it plugged in a lot longer, say overnight. Sometimes when batteries are drained to the extreme it takes a lot lot longer to charge them up and hence why you may not see any lights coming on when charging at first.

If all else fails send support@anker.com a message with your issues and steps taken to resolve the problem. Since it was a gift you may have to reach out to the gifted and ask for the order number so you can do a warranty claim, also provide the serial number of the device to further assist and expedite the process


Hi @byte8,

Thank you for bringing this issue to our attention via the community. And thanks a lot for the troubleshooting tips provided by @elmo41683.

We’re very sorry to hear that you are having problems with your PowerCore 20100 battery now. From what you’ve described, it seems the battery is defective. Could you please contact us via support@anker.com to address this issue for a warranty claim?

Have a nice day!

1 Like

Have contacted you via support@anker.com but sadly no reply from Anker
I still have all original packaging and original cables etc
Happy to ship it back as I don’t want to create hazardous waste on our landfill

Hi @elmo41683 thanks for the recommendation.
I tried a different socket/different charger (even tried USB port in laptop)
The lights stay dark. At least 1 LED should come on after charging for 24 hours
Maybe there is a problem with the charging circuit.
The cells were great and gave me many iPhone charges from a single charge as they really held a charge well until the day it died.

Give them time, as it is there new years they all have it off for the week. Sorry for their delay in response but a little more patience will pay off in the long run as I’m sure they will make things right.

If it’s been left for a long time, and completely flat, it CAN take an hour or so before you see the first light blink.

When not used for a few months, not only does it go flat, but it dies. To revive you need to charge for a lot longer on the appropriate charger. And as above, it can take an hour or 2 before it starts to show life.