Powercore 13400 Nintendo Switch edition Stoped working

Powercore 13400 Nintendo Switch edition Stoped working.

About 14 months ago I got the Powercore 13400 Nintendo Switch edition and last week it stopped charging completely. The Battery pack still lights up if you press the button but it can’t be recharged. Does anyone have any idea of how to either restart the system or is there a trick to jump start it?

I have tried using a different wall-charger and cable to see if that makes a difference but I have used I have 3 different Anker wall charger 8 different Anker cables and 2 Anker car chargers I tried everything but nothing works.

I have even followed some advice from some Anker help forms but its not working.

I have used the battery pack about 6 times in the spam if 14 months.

Any advice would help.

When you say it wont charge how are you determining this? Whats the pack doing when plugged in? These packs offer two way usb c port, so you have to make sure all lights are off before plugging it in, if you press the button and then plug it in it will output a charge instead of taking the charge

Please contact support@anker.com with this description and your order number.

i left it charging 4 different times. one time 3 hours, second 6 hours thinking it may need more charge i tried pressing the button before charge and leaving charge without pressing the button before plunging it in. i tried to leave it alone over night unplug to let it reset and tried to recharge it the next day but it did not anything.

i will have to contact Customer support.