PowerCore 13,400 (Nintendo Switch version) not working

Hi all. I’ve got a PowerCore 13,400 mAh Portable Charger for the Nintendo Switch that I purchased in Aug of 2018 that had been working fine, but seems to have stopped working this past week. I noticed it was quite warm, and when I went to plug it into a device to charge the device, nothing happened (the device wasn’t charging, no lights on the Charger). I’ve only used the official Nintendo Switch AC adapter to charge it, and when I plugged it in, still no lights or anything… Keeping it unplugged, it stayed warm for several hours. Since then, I’ve tried the reset method that I’ve seen (micro USB port -> USB C port), and tried charging again, but still no lights. I’m afraid to keep it plugged in for a long time after it was so warm previously… Would it need to be charging for a while after reset before any lights come on? Can anyone advise further? I’ve also got the PowerCore 20,100 [also the Nintendo Switch version] and that still works/charges fine with the same Nintendo Switch AC adapter (though that one was purchased more recently, April of this year).

When doing the reset its adviced to leave it plugged in for 10 seconds. But I would just reach out to support@Anker.com and get the warranty process rolling. Provide them with the serial number, your order number to help expedite the process and let then know what you have tried to do to remedy the issue

1 Like