Powercore 10400 issue - unplugged, lights flashing, not charging anything

I have two Powercore 10400 and both of them have got the same issue yesterday. Charged them fully and unplugged them to use to charge my iphone. However, the pack itself is showing 3 of the four lights on, the fourth light flashing and it is not charging anything. I’ve tried resetting (pressing button for 30 seconds). Left both unplugged all night and still the same. Any ideas anyone?


How old? I’d expect a well cared for 10400 to fail around 3-4 years old.

You describe a bad cable situation where you think it’s fully charged but is not, it’s receiving too weak a charge, usually the cable but 2nd reason is charger. The fact you said both 10400 failing implies its probably something they share like the cable or charger.

Thanks. I’ll try a different charger. The cable is the original Anker cable if used every time. Packs are just under three years old

Cables fail faster than Powercore. Different cable is always the first thing to check. Shortest possible you have.

A different charger, 5V 2A, not a laptop USB or anything that weak. Chargers fail the slowest but it’s just eliminating all causes and as you said both 10400 fail it makes me think it’s the cable or charger.

If just under 3 years old, then out of warranty and simply bad luck they didn’t last longer, usually last a little longer than 3 years.

1 Like