Powercore 10000 PD won't charge

I just recieved the anker powercore 10000 yesterday and wanted to charge it. The powerbank says it is half full (showing 2 out of 4 blue lights). It does quickcharge my phone, but i can not charge it. When i plug it in the lights don’t turn on. I left it charging all night and it hasn’t charged up. I am using the charger of my Huawei P30 pro, it is a 40 watt fast charger. I also tried a normal charger but it still doesn’t charge.

It’s meant to be charged by a 18W PD charger.

1 Like

As @professor, it be charging very slowly due to an incompatibility with the Huawei charger. If you don’t have an 18W Power Delivery charger (outputting 9V ⎓ 2A) available, a regular USB wall charger like an Anker wall charger or iPad charger (outputting up to 5V ⎓ 2.4A) should work as well, it just may take up to 12 hours to charge.

@TechnicallyWell i tried charging it that way, still does nothing.

1 Like

Try different cable also. You’re plugging into the USBC port right?