PowerConf S3 firmware update error

I’m unable to update the firmware of my PowerConf S3 (Model: A33202).

  • PowerConf S3 shipped firmware: 26.06
  • SoundCore App version on Android: v2.6.4
  • Battery is on 100%

The SoundCore App displays firmware version 29.12, but when I click the Install button I receive the message: “An errord eccord. Please try again.”

Any suggestions?

Try again from scratch.
Delete the pairing.
uninstall / reinstall the app.
Connect in app

Hi Professor, I followed your steps but the issue remains the same.

Next steps?

Do it again but after delete pairing then reboot the phone.


Delete the pairing.
Reboot phone
reinstall the app.
Connect in app

If that doesn’t work then if Android then have to delete the Bluetooth cache. This does involve a small risk so follow each step cautiously.

Either (easiest, but doesn’t work on all phones):

  • reboot to recovery, not all phones can be put in recovery.
  • wipe cache (don’t wipe data!)
  • boot

Or (doesn’t work all the time but worth a try):

  • settings
  • apps
  • include system apps
  • find Bluetooth, force stop (this may not work, if it fails ensure nothing else bluetooth is being used, try again, keep hitting force stop til it works)
  • storage, cache, wipe cache. Do not wipe data!

Insert this above after delete pairing.

I don’t have the S3 but the app would not connect to my Liberty Air2 last night until I wiped phone cache and then worked.

The cache wipe did the trick!
Many thanks Professor!

1 Like

Good to know.

If wiping cache did the trick it’s a sign of an app upgrade hadn’t worked at some point in the past. It’s part of all the tricks you’d try for anything, regardless of Soundcore.

Wiping cache may have helped something else too.

If you’re wondering why I didn’t suggest wiping cache first, it is because it does contain slightly more risk, sometimes bluetooth cache cannot be wiped in settings/apps as the bluetooth process cannot be stopped if active, so the wipe doesn’t work. If you wipe cache in recovery, there is a tiny chance the user wipes data instead which is the same as a factory reset (deletes everything). So wipe cache needs either to be the last resort, or the user demonstrates high tehnical competency to know not to wipe data by error.

Link to another fix, so whoever searches finds it