PowerConf Can't update Firmware. :(


anyone else having the same issue?

Brand New -
Opened package, turned on unit. Paired with my iphone (all apps are up to date)

  • Connects to BT easily
  • Open the Soundcore app and try and perform date.
  • Go to click the download button, cancels and greys out saying that the Battery needs to be 50%
  • Unit has been charged all day -Charge/Power light went off indicated that it was done charging
  • Even tried doing update while on charger (no luck)
  • Tried even connecting to my ipad and my iphone to see i could do the update (no luck)

Still no luck getting it to update the firmware. Really want this to work as people have trouble hearing me while on calls

any help is appreciated.


1 Like

@mikefisk7 How did you charge the powerconf - please explain? i assume, connecting the USB-C to the PC? Firmware updates do require more than 50% of charge on PowerConf to ensure these dont go into brick mode if something goes wrong on during firmware update.

Make sure the PowerConf gets charged at via the Type C at 5V/2A input.

Also, try a reset by pressing the Power and BT button together for 10~15 seconds.

Do drop a note to Anker Support support@anker.com , they will get back to you with official support response

Hey @mikefisk7
I’ve got nothing more to add than @Shenoy
But out of interest, when you say your charge light went off, did the red light go out or turn white as the guide indicates?

Hi @Shenoy,
I have charged it using the supplied USB Cable C cable and using an Anker USB Wall Charger. I tried resetting the powerconf but didnt see any flashing lights or sign of reset.

if turned off and plugged in, the red light will go off, i guess telling me charging is done.


Thanks for your response @mikefisk7

Meanwhile, are you able to use Powerconf for calls on PC/Mac and iPhone? Calls dont need the Soundcore App to be connected or PowerConf to be firmware upgraded .

I would strongly suggest you contact Anker Support at this time, and wait for the support instructions.


I already dropped a note to support… they are a little slow to respond

Its the weekend, they most likely won’t respond until Monday.

When you said you used anker usb charger, what specific charger did you use?

I have the same issue with my PowerConf. Will you respond to this thread, once you hear back from Anker?

I am using a plugin adapter. When the unit is off, there is no light while it is plugged in. When the unit is on, the light is white. When I connect it to my computer, it says it is at 100% charged. When I try to update the firmware with my phone it says it is below 50%

1 Like

I know that Soundcore App had a very recent update on App Store and hope this is not a defect introduced on iOS APP.

My powerconf is already at latest so not able to test this specific condition.

Anker Support might be able to address this issue.

I had the same issue with the indicator/charging light.
But the app always showed 100% charged even though it wasn’t. There obviously something not quite right between a certain version of app and firmware version of the unit.

Soundcore app updated this morning on my phone. I was able to do the firmware upgrade after the app updated.

1 Like

was there anything you did or was it just the Soundcore Update? I feel it is the Soundcore App which fixed the issue

Great news @Pynuts :+1:t2:

Looks like Soundcore App Update has addressed the defect.

New update is available now,

I unexpectedly found a way to update the firmware on my PowerConf S3.

  1. Connect the PowerConf USB-C port to a charge point (in my case a PC) via USB cable.

  2. Connect the PowerConf to your Android phone SoundCore app via Bluetooth.

  3. Perform the update via the SoundCore app. This time it works.

Earlier efforts (before connecting to a charge point) resulted in the firmware update download succeeding but the install operation failing.

No idea why the PowerConf S3 had to be connected to a charge point first. My PowerConf S3 had recently been charged up.

1 Like

Thanks for investing the time to find and share the fix. Hopefully some future search finds this!

If the Powerconf under-the-hood is a version of Busybox or Android then this does make sense, the TCP/IP path is over eth0 and the connection over bluetooth TUN failed. You can get similar with Wear OS updates.

I updated my answer. Pretty sure it was purely a power issue seeing as my USB cable went from PC to the charge USB port on the PowerConf S3.

Pardon the earlier red herring!

1 Like


Appreciate the continued honesty. Searching needs to find the answer.