Power Bank to power Raspberry Pi 4 (USB-C 3 Amp)

Are any of the Anker Power Banks capable of powering the Raspberry Pi 4 over USB-C to provide 3 Amp continuous power in the field? I don’t believe the Rpi4 is using any of the intelligent power modes. The wall plug unit mine came with isn’t a smart charger, but does provide 3 (actually 3.5) Amps over USB-C.

1 Like

Raspberry Pi 4 requires approx 5V at 3A

Powercore 26800 PD+ provides these output

There may be other models as well but Powercore 26800 PD+ is recommended since it has USB-C PD output. Mentioning this since it is fresh in my mind. Will add more in sometime

PowerCore 10000 PD and Powercore+ 20100 would work for this one.

1 Like

Like shenoy mentioned, provided you find a bank thats Power Delivery (PD) conpliant you should be fine. The way to be sure its PD is to verify the ouput is USB-C and not the older USB-A.

1 Like

Also since there were issues reported with USB-C for RPi 4 ( not sure if this is resolved) , only few cables were tested to work well with it.

Below are 2 of Anker cables tested to work

  1. Anker Powerline USB-C to USB-C 2.0 Cable (3 feet)
  2. Anker PowerLine+ C to C 2.0 cable (6 feet)

Link to original article on community:

1 Like

Thanks. Yes, it was this Ars Technica article that made we wonder whether there was a power bank / non e-cable solution. https://arstechnica.com/gadgets/2019/07/raspberry-pi-4-uses-incorrect-usb-c-design-wont-work-with-some-chargers/

I picked up the Anker Powercore 10000 PD redux for my new Raspberry Pi 4 - and am getting periodic lightning bolt (aka under voltage) icons on my 7” Pi touch display - at startup, when launching apps - and periodically when not even using the UI.

Anker fully charged with Apple USB-C power adapter first.

I tried with both the included USB-C cable - and also the Anker Powerline cable everyone is recommending.

WiFi and v2 camera are in constant use streaming video - nothing is plugged into the USB/Ethernet/HDMI ports.

YMMV with this device - but I don’t think I’ll chance the SD card corruption. Back to looking for a decent portable PSU for the Pi 4…

Everything works fine with same setup and Canakit wall plug.

Will monitor this thread to see what works for others, or suggestions.

I did run apt-get upgrade to pickup the Raspberry Pi 4 update released in December that is supposed to reduce power needs.

I stopped the RPi webcam interface running on a thread in the background - but still get the Lightning bolt. I was hoping that would make a difference. Really don’t want to remove the Pi display to reduce load further.

https://elinux.org/RPi-Cam-Web-Interface

I may have found a solution that let’s us use Anker Powercore 10000 with the 7” Raspberry Pi touch display.

The display uses a case with a USB C splitter cable - with one leg USB C to the Raspberry Pi 4, and the other a USB B to the touch display.

https://smile.amazon.com/gp/product/B07WXK38YM/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

Since the Powercore 10000 has two power ports - I removed the splitter cable, and ran a direct cable from the USB C to Raspberry Pi, and a second cable from the Powercore’s USB A power port to the display.

I’m no longer getting under voltage errors - even with the webcam interface enabled. Time will tell, but this looks like a workable solution.

I think I’ll try to get some 6” USB cables, so that I don’t have these long cables attached - but it seems to work fine now with the 6 foot long cables.

1 Like

@mrmiddleton thanks for the follow-up and providing the solution you found!