Power Bank not charging devices

I have an Anker Power Bank PowerCore+ 26800 PD. It has suddenly stopped charging the devices that I had connected to it while on a flight. When I connected the power bank to its charger, the power bank would get charged, but it won’t charge any of the devices. When I pressed the button to see the amount of charge, it instead flashed five of the ten lights alternately. I have tried to reset it by connecting the USB-C port to one of the USB-A charging ports, but to no avail. If there is a way to repair the device, I would be extremely grateful.

Try leaving the power bank off for 15-30 minutes so any safety circuits can reset. If the issue persists, feel free to reach out to support@anker.com for assistance!

1 Like

I think… Don’t quote me

If you press n hold the power/on off button for 30 secs, it’ll reset… I think‽

Have you tried different cables?
What are you charging the powerbank with?

contact support and see if it can be replaced under warranty

I was charging the power bank with the provided 30 watt adapter and cable. I have tried charging the powerbank with my Mac cable and it does get charged. I tried charging my devices, i.e. iPhone and iPad with their own cables. Unlike before, they weren’t getting charged.