Notifications for HomeBase/EufyCam

Is anyone having issues with notifications and EufyCam/HomeBase? Mine is recording video fine but doesn’t notify me.

  1. Base Station and Cameras on latest firmware.

  2. My Arlo Pro 3 system is notifying me fine and on the same network so it can’t be internet/home network related. I have a very stable internet connection.

  3. One of the cameras is behaving fine. It is the one on only 2 bars of Wifi strength.

  4. I’ve ensured Push notifications are turned on in the security modes and Notification Settings for the individual cameras themselves (All Alerts).

  5. I’ve tried reformatting the SD card and restarting the homebase.

  6. This is a new out-of-the-box setup.

Any help would be very much appreciated.

My system is working fine and see no issues.

Was it working before and stopped sending notifications suddenly or you never got notifications from that camera?
Try deleting and re-sync with the home base.

Send an email to or use their live chat in the app.


I’m not having any issues either.

My first go-to is always restarting the HomeBase. If that doesn’t work, I try logging out of and back into the app. Then I try the more “drastic” measures, like @Ice1’s proposal.

Let us know what happens…

@Ice1 - Each of the cameras worked when I first added them to the home base. But something happened after I setup a new security mode to turn on cameras without the camera alarm sounding.

The fix…after a few days of playing with them appears to have been discovered by accident. It may be a firmware bug on the homebase or on the camera. I can’t tell. So here’s what I did to fix the cameras: I setup Activity Zones for each camera. One by one.

So now, my android device is getting all the notifications from ALL cameras.

The funny thing is…the iOS client still isn’t getting them which makes me wonder if activity zones are stored on my mobile device. Any clues?

Something is quirky here. Without having the logic/algorithm of how the homebase or camera (or both) sends out notifications, I can’t tell which one is misbehaving.

@ichthus14 - thanks. I’m not going to delete/re-sync yet until I get a better understanding as to what might be the cause. I grew up with this mentality because unlike some, I don’t turn off/on computers because they misbehave. I like to find root cause so I don’t have to keep turning them off/on.

Anyway, I will probably give up and do exactly as what Ice1 had suggested. Worst case, I’ll file a bug report to Cheers.

This happened to me too. Deleted the app, reinstalled it and logged back in. Everything was as before - all the camera settings remain in place anyway.

This is weird. The notifications should work alike with both OS as the zones and settings are done to the eufy system.

I believe this is where it happened but not the firmware.
I would delete my security/alarm settings and test it. Then one step at a time set alarm and so on and continue to test.

Its all good now. Had to wait 24 hours. Now the iOS client is getting all the notifications as well.

Does anyone understand how notifications are managed? For example, are they pushed out by the homebase?

With regards to the security mode. I’m not touching it for now. Its all working perfectly right now. I think there might be an inconsistent bug with either the cameras or the homebase or both triggered by changes to the configuration. If Eufy publishes the firmware as open source, we might be able to help them isolate the bug! :slight_smile:

One day perhaps.

I believe they are pushed by home base. I could be wrong.

I’ve had exactly the same issue with my setup. Notification were working correctly, but have suddenly stopped. Any fix in sight?

I would think the notifications have to be coming from the HomeBase, since it is the system’s connection to the internet, where the “application server” lives (on AWS).

Reinstalling the app worked for me. Advice from eufy support.