Not Logged into Power User

I noticed when I login, then click on the Power User link it takes me to a page that looks like I’m logged out and has links to apply. I no longer see a list of things I had previously reviewed.


1 Like

I tried it myself… Seems to be an issue with Power user page on Anker. Power user is almost retired and not relevant after “We Love Testing” was started in Anker community.

@AnkerOfficial can you please check and let us know if there is an issue on Power user section .
Also if Power user section will be completely be retired?

Nice catch! It must have finally died.

The power user page has always asked to be logged in if you have not done so in the past 20 or so days. Once you log in, even if this site says you are logged in you should be able to see all your previous items you have reviewed.

I make a habit of logging in and out every week now. Just so I know I am able to I access any of ankers sites

Even after login, it is not showing up the section… Comes back to login page…

It works and shows for me, so I dunno what to tell yall

Thank you @Tank for posting …

May be it’s not impacting all… And some of us (at least me and @sy18401)

When you go to the power user page, try clicking on apply. When it ask you to log in go ahead and log in and it should bring you back to the power user page. I just tried it from my desktop on a new browser, in case there was saved cache images, and it worked still. So maybe give that a try?

When I click the apply for power user and log in, it just brings me back to the apply page again instead of letting me see my page as well. Maybe @tank is just the super user😋

Yea it’s being doing that for as long as I can remember. You just have to log back in, but to be honest, I was wondered why and the forum pop-up as different pages. All you need to do is click the little profile guy in the top right and sign in, which sometimes happens automatically. As long as you have been approved then you’ll see your PU item history and/or any available PU products.

EDIT: So ^^^ used to happen as of yesterday, now I am also getting kicked back to the same screen. Which is not good because I have a review to submit!

@SlyBandit247 the review you have to submit doesn’t go there, you need to click on the testing club and post your review link there

Too I could never become a power user

Hey @sy18401 the Power User page is working for me now. Check for yourself. I have been checking everyday since you posted this and today it finally came back. To me it seems like they did some code re-working, the page responds better now. Anyway I hope it works! @Shenoy

Thanks for the heads-up @SlyBandit247

Tested it now, and PowerUser page seems to be working now … would have rather wanted it to be retired :smiley:

1 Like

Oh yea it wasn’t the official review. I thought I stated in the first sentence “This is not a final review”. That was just me giving a tiny bit of feedback. That would be a pretty pathetic “We Love Testing” review. That would have been like “Meh, it’s Ok…” lol. It should be up in the next couple days. I like to wait like 2 weeks to make sure nothing happens that would make me have to completely change my review.

Ya, it’s working now thx!