No high quality headset possible with Anker Soundcore Life Q20?

Bought 2 Soundcore Life Q20… - paring works fine. For a windows machine, an additional [Hama Bluetooth USB Adapter (Bluetooth 4.0 C1 + EDR) is in use to rule out problems with the onboard bluetooth. Drivers are up-to-date and used by the dongles manufacturer (Hama).

Well what is the problem now?

The Headset is supplying 2 bt devices: handsfree and heatset. With headset you have a good stereo sound but NO acccess to the microphone.
On the other hand, with the handsfree device you have access to the microphone but only crappy mono sound with a very, very low bandwith. For my taste, normal GSM phonecalls have a better quality.

The moment you access the one - the other is deactivated.

Is there NO way to have your audio signal routed in stereo in good quality AND access to the microphone?

If that is impossible, then I guess its best to get rid of that headsets :frowning:

Whats wrong with the onboard card?
Or is there no?

device 1: mSI mainboard non-bluettoth but hama dongle.
device 2: Surface pro with bt
device 3: Lenovo miix 720 with bt

same behaviour…

is there a configuration example where you can use high quality stereo together with the microphone?

Now its more clear and could be answered by other LIfe Q20 users.
Think you will get some answers, (Don’t have the Q20)

Don’t own the Q20 but I’d suggest pending a better reply, nose around in the Windows Sound settings, it may be different defaults?

again: can anyone confirm that it is possible to use the microphone together with the hi-qual stereo?

You’re not encountering enough Q20 users here who are bothered about microphones. So it’s a weekday now so you should get a reasonable response from email service@soundcore.com , they may, and probably do, know more than you get here.

https://www.soundcore.com/uk/contact

Hi, is there any publicly available solution to this issue?

At the moment there is no option for me to have the high quality option anymore, only the Headset low quality. This really makes the whole experience of using the headphones awful!

Thanks in advance!

octav_spike: No help around. frustrating.

Have same issue if any one has a solution would greatly appreciate it.

1 Like

Same issue with Dell XPS 13, Windows 10 v.2004. No audio in headphone settings, only headset.

For your information: Anker contacted me and sent me 2 replacement headphones. Unfortunately, they have all the same issue.
Fact is: as soon as you use the microphone, this product switches from “stereo” to “handsfree” profile and reduces bandwith to a very, very low “speaker optimized” value. Terrible quality - even worse than normal IP phones.
I dumped all 4 of my headphones. :frowning: