Nintendo switch power bank not working


I just bought the anker nintendo switch version with 20100. When I press the button the lights blink for a second before going out again. Tried to charge the switch and it does work, pressed the button once like the manually says it doesn’t work. Tried to press it for 10 seconds without any cables putted on and tried to again, didn’t work. Tried to charge my phone with the USB-a, doesn’t work. I fully understand charged the power bank with the Nintendo charger, but it’s still the same after charging. What can I do?

Things i tried:

Different cables (all the cables works on my other anker powercore+)
Tried the complete circuit method. same cable from USB-A to USB-C and wait 30 seconds.
Tried the button option once to charge and two to stop.
Tried the 10 second button option.
The power bank is fully charged.

Already emailed to anker support but they havent answer yet.
Just wanted to know if you guys know any trick or know something about it.

I got the powerbank today, so its brand new.
Thanks in advance

You have tried everything I can think of, I believe you got a defective unit, I would continue with Anker support to resolve the issue.

Sorry to hear it’s giving you trouble. Indeed it looks like you’ve tried everything. Anker support doesn’t typically reply on the weekends, but you should hear back this week. There is also phone support available during the week as well: