New Powercore 20000 won't fully charge

Received my brand new Powercore 20000 and started the initial charge early Friday afternoon. I’m using the Anker supplied cord attached to a 2.1a wall plug. Started off on Friday with 1 solid light and 1 flashing. Changed to 2 solid 1 flashing Friday night and it is now Sunday morning and 40 hours later and still the same 2 solid 1 flashing. Any ideas? Thanks in advance!

When you say your using a 2.1 amp charger, what charger is it and what are the rest of the specs of said charger? Is it a phone charger? What else can you tell us about this charger

Hi Tank,
I’m using this:

IESSENTIALS IE-ACP-2U Dual USB Home Charger-by-IESSENTIALS - Dual USB Home Charger

  • Compatible with iPad®
  • Charges 2 USB devices at the same time
  • Works from any wall outlet
  • Compact design for easy storage

What’s on the plug is this:

Input: 100-240V AC 50/80Hz 0.18A
Output: 5V=max 2.1A

Hope this helps!

Do you have anything else plugged into this charger? From what i read about it it splits power output between both ports so your essentially charging your pack at the lowest speed of 1a which is why its taking soong to charge.

If you give me the exact model of the powercore you have i can better recommend a plug to properly charge it.

The plug has 2 ports but I’m only using one port with the supplied Anker cord that came with the battery.

What I have is:

PowerCore Speed 20000 Qualcomm Quick Charge
Model A1278

As i stated before that plug splits power between the two ports, so even when using just 1 plug it still only outputs 1a.
You need a quick charge 3.0 wall plug to properly charge that pack at optimal speed. This plug is what you need


Looks perfect. Just ordered and should be arriving tomorrow. Thanks for all your help!!!

Glad to have helped, if you need anything else feel free to ask. Also, you can mark this as solved in your original post

Ok thanks. This was my first post so not sure how to mark solved. Is that the badge icon?

Its cool, and im not even sure cause I havnt asked a question myself before

Desperate much?:wink:

Seriously? Not desperate but if he marked it as solved then we wouldnt get a flurry of posters posting the same thing. And if someone else searches for simar issue they would be able to see this was answeres and can look to see what it was without having to keep searching

I am more than sure that since you were the first person to answer this question somewhat and technically correctly that marking the answer solved will be handled by the by the OP a site moderator or @AnkerOfficial . Sit tight you’ll get your bucks.

But hey you do you.

@blackzzz I would have recommended any Anker charger with quick charge 3.0 or (Ankers Power IQ 3.0 capable of quick charge 3.0 it’s also backwards compatible with QC 2.0 ect & power delivery or PD for short)

The single port charger that was recommended while being the cheapest option is just that “single port” and not very flexible depending on your charging needs.

I was pretty much just looking for something that will charge the battery quickly and efficiently.

1 Like

Then his recommendation was perfect :ok_hand:

1 Like

So I got the Anker 3.0 Quick Charge plug yesterday and the battery has been plugged in for 20 hours. It still has not gotten past the 2 solid 1 blinking light. Pretty damn frustrating. Guess I’ll be making a call to Anker today. Apparently I got myself a faulty brand new battery right out of the box.

Ouch, Sorry to hear that bud.:man_facepalming: Don’t let this experience leave a bad taste in your mouth. I have yet to receive a faulty powercore and have many in a variety of sizes. Anker will take good care of you sit tight.

1 Like

Just got off the phone with Anker. He said to do a reset and try again. I’m to give it 6 hours and if nothing changes call them back and will move into warranty mode.

1 Like

@AnkerOfficial @AnkerSupport should really include basic troubleshooting steps in the manual. It would save them a ton of man hours and minimize the number of frustrated customers. Something like,

Troubleshooting steps you can take

  1. try a different quality cable
  2. try a different power source
  3. reset procedures / button combinations to reset for speakers and headphones & how to create a power loop that resets Power Banks.

Also This troubleshooting guide should be placed in a prominent easy to find and see (bold or italic letters) place.


To add to your third on, leave the powerloop plugged in for 10 seconds to fully reset the internal mechanism. Thats what @AnkerTechnical said in the past to do for powerbank resets