New Homebase 2 led blinking red after initial update

Hi Everyone,

I just bought a 2x Eufycam pro setup (and some 2k battery doorbells to go with it) and upon first syncing the homebase 2 with the android app, i started updating. It blinked red and blue for some time, and then switched to blinking red, and since then its been unresponsive.

I’m not sure what happened under the hood, but it seems the update somehow bricked a brand new homebase.

A quite disappointing thing, I have tried contacting Anker support yesterday to ask for help, but only got an automated reply. Before I pack it all up and return all the equipment, I wondered if any of you had any tips on getting past this. I have tried doing a hard-reset with the included pin, holding for 15 seconds, but this didn’t help.

Thanks in advance for any tips/ideas.


1 Like

Just as an update to this post, having contacted Eufy support (and going through the URL check, changing network cable etc etc) their only measure to resolve this issue was to ship me a new homebase.

In case this happens to you, just know that unfortunately its likely a warranty replacement.