New Eufy Indoor Cam 2K "No Response" in Homekit

I just bought two new Eufy Indoor Cam 2K cameras with the intention of using them in my Apple HomeKit environment. According to the instructions I first added them to Eufy Security app, upgraded the firmware (now then added them to HomeKit by using the HomeKit Portal. It all went smoothly, they got added to HomeKit successfully. But when I look at them in Home they both say “No Response”. They both work perfectly in Eufy Security app.
I tried removing them from HomeKit (multiple times) and adding them again, no change.
I tried removing them from HomeKit and Eufy Security (multiple times) then added them again to both, no change.
I tried resetting them (by pushing on the back button for 10 seconds) then repeating the whole process, no change.
All devices were restarted several times (hub, cameras, iphone).
All Apple devices are running the latest versions of iOS (AppleTV Hub, iPhones, iPads).
I even tried created a different account for Eufy Security with location set to USA, no change.
Am I doing something wrong or are these just not HomeKit compatible?


You could try to get help there :

Reads as though it should be HomeKit compatible @Jur1
Does Apple have an opinion on the situation?

I had the exact same issue, everything as you are describing it. After having given up at first and using the camera without HomeKit for some months, I have now completely deleted my HomeKit configuration and set up a new Home, and after that the camera now works perfectly fine with HomeKit Secure Video as it should.

In case it matters, the Indoor Cam 2K now was the very first device I added for the fresh Home configuration.
Even before adding any HomeKit Hub like Apple TV or HomePod. I don’t know if that played a role.