Netflix cant connect to Nebula Capsule - error -200


I have a Capsule and am unable to get into Netflix. The login screen opens OK, but entering details I am given error screen with a -200 error saying that I cannot be logged in at this time and to try again later. A quick bit of research tells me its a connection issue.

I have tried some suggested fixes - I have cleared the app cache and data, tried uninstalling the app, changed network and also reset to factory settings…none of these work.

Netflix suggest going onto another PC on the network and going clearing cookies via netflixcom/clearcookies (tried this also).

Please can someone lend a hand with how to fix this??



Sorry to hear that the issue you experienced. The -200 error typically points to a network connectivity issue that is preventing your device from reaching the Netflix service.

In your case, could you please also try your phone’s hotspot to see how it works? Please make sure that the Date&Time on your Capsule set up correctly. If the issue remains, please contact our customer support at with your Capsule system version (settings>about>system version) so that we could verify and assist further.

Thank you!

Anker Support Team

Hello, I have tried this also and still getting the same error… Any further advice? (device Capsule Max, system version M2C_V2.0.41, android 8.1)