Nebula Prizm ii - Firmware update?

Hi,

I am the proud new owner of a Nebula Prizm ii, and i love it so far!

My only issue is that it has an awfully laggy menu,and limited settings. I was hoping that a firmware upgrade may be avaliable somewhere to fix these issues. However, i have not been able to find a firmware upgrade anywhere on the internet. So either i’m not looking in the right place or there has been no firmware updates for this model?

Thanks guys!

2 Likes

Welcome to the community @Yoni_bz!

I’ve found this for you on how to obtain and install firmware updates for your Prizm ii if any are available for it.

I hope this helps you out a bit. :slight_smile:

2 Likes

Hi,

I did have a look at the manual. When i went to the site it mentions, there is no download file on that page for the product?

Here you go…

Go to nebula.com and then follow the pics!

1 Like

When you click on Nebula_D2240 it just brings up the instructions for it, Mac

@Macgyver15

I got this from the robot!

Live800 Robot

20:46:17

Agents are offline, please enquiry to robot or leave a message to agents.Leave message

Hello, robot is here for you!

Where is the software update for prime II

Similar question

The device is constantly crashing.

Corresponding answer

  1. When Capsule is powered off, press and hold “Volume+” and “Power” buttons simultaneously for about 4 seconds until Nebula screen appears. Then Android’s robot logo will appear on screen.
  2. Then, press and hold “Power” button, follow by pressing “Volume+” and the Android Recovery screen appears soon.
  3. Press “Voulme-“ button to skip to “Wipe data / Factory reset” option.
  4. Press “Power” button and choose “Yes”, system will automatically jump back to Android Recovery screen after factory reset is done.
    If these suggestions don’t help, please contact us at support@seenebula.com for further help.
1 Like

Thanks for taking the time to send those, but it only shows the manual, not the firmware?

I would suggest you contact Nebula support directly On support@seenebula.com.

Also they can be reached on chat here

https://www.seenebula.com/contact

1 Like

Did you do the new instructions? Or did I waste.my time?

Hi,

I did them, but i had already tried this before.

One of Anker customer support team had sent me the file to install as its not available on any webpage.

1 Like

Since Nebula series a niche product from Anker Nebula team, not many members or users have these yet, except a handful of community members since the price is a bit… hmm… :dollar: :dollar: :dollar: :dollar:

The best approach for any / all users with Nebula, seeking answers / resolution with Nebula Products is the Nebula support team.

They have great support, timely responses, reachable via email (support@seenebula.com), Chat and Phone (US TollFree 1-800-988-7973 Mon-Fri 9am-5pm PT)

1 Like

Did you find the information you were looking for?

They have sent me the file, but the file is corrupt/doesn’t work when i plug my USB into the projector!

Have you reached out to support with this info, most of the time, the USB drive used with Android devices need to be formatted with FAT32 (or as suggested by Support).

Can you format the USB stick with FAT32, download fresh copy of the file the support sent you and copy it into the root folder (main folder as soon as you open the USB stick), and try the firmware upgrade.

Do keep us posted with your results / what you hear from the support.

1 Like

I have reached out to support and explained to them that, i have tried three different USB, all formatted with FAT32, on Windows 10, and downloaded the file again which was reuploaded by support. I still recieve the error saying firmware file not found.

Did support send you a zip or compressed file?
Did you unzip the file to USB stick directly without any subfolders?

I am sure you have already performed these steps but reiterating :slight_smile:

  1. Please download the firmware, decompress / extract the zip ( if the file came as a compressed file) and get the file.
  2. Format the USB such as FAT32
  3. Copy the file into the root folder of your USB (not any sub-folder).
  4. Insert the USB stick to Prizm and initiate Firmware update.

I am using 7-zip and Winzip and neither allows me to open the file to extract the contents. I didn’t realise it had to be extracted. The file extension is .gz but both programs refuse to open it?

If using on Android, try FX file app. It’s extracted zipped files for me on my phone.

Try Winrar ( WinRAR archiver, a powerful tool to process RAR and ZIP files) choose and download 32/ 64 bit… and use it to extract the .gz file format.

Then follow these steps

Thanks for the advice!

So i managed to extract the file using winrar, and then i am left with a single file. I have put this on a FAT32 formatted stick, and i am getting the same error.“USB Drive Firmware file not found”