Nebula Mars Lite EXACTLY what video/audio codecs does it support?

I have a Nebula Mars Lite projector and I’m trying to transcode some MKV files so that I can play them back from a USB stick. I tried using both VLC and ffmpeg to do a simple MKV > MP4 convert, but the projector says the video file is an unsupported format.

Can anyone specify exactly what formats/codecs this projector supports? Lots of googling has turned up no specifics on supported video formats.

Because the nebula uses OTG adapter it’s file system format is based off of USB file system: FAT32
Make sure your card is formated this way first and then add your files. Most cards are defaulted to ntfs format and that may be why you are seeing this message

Good to know.

But, a filesystem issue would mean the file could not even be seen to give the file not played error.

Codecs, I do not know the answer, but recoding in general I know well, I use ffmpeg and simply let it default to mp4 which is h264 for video and AAC for audio.

I have been tempted to recode my videos to h265 for file size reduction, I did an experiment on a range of media players and hit issues similar in nature to this one (I don’t own this device so don’t know).

Try this

ffmpeg -i input.mov -vcodec h264 -acodec aac -strict -2 output.mp4

1 Like

Good luck :+1:

I have seen the system read a drive even if its not in fat32 and it would still display that message that its unsupported.

With that said, I have used MKV files, MP4 files using the stock video player and had no issues. But then again I have the Mars II and Capsule Max, so it may not exactly be the same.

@Mark_Marino1 have you tried straight up using mp4 or mkv files without trying to convert them?

1 Like

In the absence of my precise knowledge, I’m just guessing. The older the format the more likely it will intersect the supported codecs. As a read-across check the oldest Chromecast supported combinations. It’s not just codecs but the combination of video codec and audio codec.

Try to adhere to these as a guess, check the oldest Chromecast here

H.264 High Profile up to level 4.1

I owned the Capsule Max and it simply played my MP4 no issues off a SD card which was I think FAT32.

1 Like

I’ve tried a number of USB sticks/drives… I made sure they were formatted to FAT32. It would not read my exFAT formatted drives. It seems to read drives up to 32GB but it choked on a 64GB SanDisk Cruzer stick.

Re: MKV files working for you… I suspect the Mars Lite may have more limited codec support. I’m going to try experimenting with some other MKV files to see if any of them will play.

It does play my MP4 files, but most of the files I have these days are in MKV containers. I’ll try a few more more MKV > MP4 conversions with ffmpeg, but so far, not having much luck.

I’m using FAT32 formatted drives. It can read the USB drive, it can’t read the video file format.

I’ll give that a shot. The ffmpeg command I was using was:

ffmpeg -i Jaws.mkv -c copy Jaws_ffmpeg.mp4

Which more or less just copies the existing codecs from MKV container to MP4 container. I may have more luck with your command as it looks like it forces a transcode to h.264 and AAC audio.

Thanks!

If you add -t to the command to do just the first few seconds so you can experiment faster.

e.g.

ffmpeg -i input.mov -t 10 -vcodec h264 -acodec aac -strict -2 output.mp4

just does the first 10 seconds.

Correct this actually recodes, so compute intensive, hence why prove it out quickly with -t option, to a old common combination. This is not necessarily the most efficient, you may be able to copy say the video stream and just modify the audio, say, to get overlap what the Mars can do. As I said, I’m guessing from other device experience.

If you find the resulting file size is large then I can help with reducing quality, as the Mars has a low resolution and low performance you should be able to tune the resolution and frame rate to be no higher than the Mars can handle.

Do the first few seconds to prove it works at all, then try the first few minutes to prove out the picture and audio quality, and tune to size, then once happy do the whole file recode. When I’m tuning for smallest file size I do about -t 120 for 2 minutes then scale file size by media duraton relative to 2 minutes.

If our replies are helpful please click the solved button on the replies. Thanks.

I want to recode all my files to h265 but not all devices I’d want to play on support it yet, that would roughly half the file sizes for similar quality. I’m keeping on h264 as it works on everything.

1 Like

This is great information, thank you! I tried converting using the command you specified and the Mars Lite STILL would not read the file. I was hosting a backyard movie night, so I ended hooking an Intel NUC up to the projector and just played the movie using VLC under Win10. Movie played fine but occasionally would glitch, especially on very busy scenes (in Jaws, it seemed to sputter on any wide open ocean shots especially). I think it’s just the NUC (i5 based) is getting long in the tooth and choked on the 1080p file. So with that said, if I wanted to transcode down to 720p for the Mars Lite and keep the file sizes relatively small, what would you recommend for ffmpeg settings?

The original file looks like it was encoded as h265 with DTS audio, which probably explains why my little NUC couldn’t keep up with the video sometimes.
2020-06-28_14-16-11

If I didn’t have 14 socially distanced people in my backyard waiting to see the movie, I would have tried playing the transcoded movie instead of the original h.265… but I had no network, so I went with what I had. Here’s the MediaInfo on the transcoded version… not sure why the Mars Lite refused to play this one, it looks like it should have been OK. Any thoughts?

2020-06-28_14-22-14

OK, I am guessing to a degree so consider my info about 70% probability correct.

So the test recode would not play. I’m stumped. An old codec combo, h264 + AAC should have played. I think we need official response. Send email to …

I attempted to look it up. Not a good response.

Downsampling to the target device’s maximum capability helps everything, reduces file size and means the server which processes the file does the hard work and the projector has an easier job.

Is the projector truly 720p? I seen somewhere (not necessarily this product) the resolution is not what is said. Anyhow, assuming 720p…

Add

-vf scale=-1:720

If the resulting file is too large then add

-crf 27

Do a 2 minute test -t 120 first before the hours of recoding.