Nebula launcher keeps closing

Hi everyone ! Custosmer in distress here !!
I just received my nebula capsule, only had time to connect it to wifi and download a bunch of apps and now it’s already not working !! :sob:
I was installing YouTube as everything closed. A small android window appeared saying “Nebula Launcher has stopped” and now as I click on openning the app again it just keeps showing the same window again and again. I cannot access anything, not even the set ups to reset it. Please can anyone help ? :pray::pray::pray:
I am in France and bought it on Amazon through a friend’s account so there is absolutely no possibility of taking it to a store to repair it…

When you say app, do you mean controlling the capsule via the app causes the issue or the physical OS / app on the Capsule itself gives the error?

A couple of things you could try…first…possibly a stupid question/suggestion but have you tried a restart (press and hold power button for 2-3 seconds until powered off). Power back on and try app again. Second…if you have access to the settings menu you could also try a factory reset to clear whatever install / loop issue you have.

Failing any of the above resolving you can reach out to or for further assistance such as how to complete a hard reset without the using the remote / mobile app…

Thanks for your answer ! I think it is the OS, because I can’t access anything, not even the setting menu, so I can’t reset… And yes I keep trying to turn it on and off but that doesn’t work, it just brings me back to the same error