Nebula Cosmos Max - Netflix stopped working

So far I’ve used Netflix from the Nebula Manager app. It’s an older version, but worked fine up until last night.

Ever since, I’m getting the “current media cannot be played immediately - 1044” error. Tried sideloading the latest official version, but it says the device is incompatible.

Can we expect a fix in the near future?

1 Like

I had the same issue with the latest Netflix TV App. I still had on my cosmos Max the netflix ‘tablet’ version and this one is working (with the mouse on nebula connect app).

I am waiting for the support answer.

and here the answer from Nebula support:

*"In this case, may I bother you to uninstall and reinstall the Netflix app V6.26.1 version through the Nebula Manage app to see how it works? The current supported Netflix app version is a mobile version, so we would have to recommend you use our Nebula Connect phone app’s mouse mode to control it. *

We understand the operation is not very user-friendly, and the team is still working hard to see if any better workaround we can offer. At this moment, we will have to bother you to try in this way. "

Yeah, I’ve already reinstalled the app from Nebula Manager, and it still installs the previous TV version of the app that doesn’t work anymore. I’ll try again a bit later.

Okay, after some struggling I got Nebula Manager to show the “new” Netflix version.

It’s indeed the mobile/tablet version, and resolution simply sucks. I think I’m not even getting 720p, most of the things are so distorted…

1 Like

Are you sure your Netflix account plan allows for better?

I’m on a tablet now watching the standard HD so 1080p on a 11" screen and I see scope for image improvement, I imagine I’d spot the quality even more on an even larger screen.

I see the Nebula Cosmos Max is 4K so you’d have to be on the Premium level of Netflix.

Go into Netflix, App Settings, Playback Specification and see what it says, e.g. my tablet is physically capable of exceeding Full HD but not 4K so there’s no point for me to be on a Premium Plan, my NetFlix plan is Standard so I’m paying for Full HD so I’d expect Full HD, and it is. Yours? You should pay for 4K plan as the projector is capable of it, but check the playback specification first to see if the Nebula hardware and the app are capable of 4K.

Screenshot_20201020_213353 Screenshot_20201020_213621

I’m on the highest tier of Netflix because I have two more people on my account (each with a single device), thus I need the 4-screen package.

The tablet version running on TV will be crap in quality since the Widevine protection level won’t be high enough for proper 1080p or 4K playback. It will default to 720p or worse.

OK so if I read this all correctly, this projector is a max of 720p on a 4K claim, for Netflix, and you’ve done everything Nebula support told you.


If so, then I’d say if NetFlix is important for you, don’t buy this projector, until Nebula come up with a solution.

The @professor telling it how it is

1 Like

Is the playback specification screenshot you took from the Nebula Max?

Because I just checked mine, and it reports maximum playback resolution as SD, due to Widevine being L3 (not secure) instead of L1 (properly implemented DRM).

Also… Don’t buy this projector until Anker fixes it? How do I do that when these issues only show AFTER I bought the projector? It’s a bit of backwards thinking. Hindsight is always 20/20…

No, I don’t own any Nebula but familiar with Android.

This is why you wait for a review before buying. It’s not hindsight, it’s foresight to always wait a while after products release or be prepared to suffer more bugs longer.

I’m sure Nebula will find a fix as it’s software versions issue, but if you buy a product early then the bugs are going to be more common initially.

Let the community know when there is a fix so those waiting to buy know when.

Usually Anker is good at seeding for free the testing units so users can find what the product team hadn’t spotted, so does anyone know what went wrong here?

So you’re commenting here without actual experience or expertise to solve the issue.

It is hindsight at the moment, since the Cosmos series was released months ago, yet there aren’t many reviews, and guess what, none of them actually touch down on the topic of Netflix. The closest you get to it is a mention that the Cosmos series supports it - although that review was written when the OS of the Cosmos was still just regular Android, not Android TV (important difference!).

Which is why I made the post, so that Anker/Nebula are aware of the issue and can fix it promptly. The current recommendation (using an older tablet APK) is not exactly usable, since, as I said, the quality is restricted to SD only (so, 480p), due to the Widevine protection being implemented the wrong way - the Netflix app only recognises it as L3, even though proper L1 level implementation is available. If the Netflix app recognised it as L1, then we wouldn’t have this discussion (note: there are ways to patch the Netflix APK to recognise everything as Widevine L1, but for some reason Nebula decided to forego this patch. The APK distributed through the Nebula Manager app is already patched, so I don’t see why this was skipped).

The issue here is Netflix. While on “regular” Android they depend on the system telling them certification details (mainly, device model/manufacturer, Widevine level, etc.), for their TV version of the app, there’s a separate certification process. Except Netflix is a massive asshole, and only certifies products that have a certain number of sales (i.e. certain number of users). Xgimi’s projectors also have this issue, the official app, even though available through the Play Store, will not launch, claiming error code 13 or 14 (unsupported device). Right now, as far as I can see, the user count of the Cosmos is somewhere between 1300 and 5000 - the Kickstarter alone bolstered over 1300 supporters, and I’d guess since it’s available on the market now, a lot more people have bought it. But that’s apparently not enough for Netflix to actually certify the device.

The reason why the previous app stopped working is because Netflix updated their servers, and I guess this version is no longer supported (it was a ~2 years old version, v6.6.x). The replacement is a patched 7.x version, which works, but as I said above, fails to recognise DRM properly, thus falls back to SD-only qualities.

Right now all Nebula can do is try to make a patched version they can distribute in the meantime, until Netflix is willing to certify this projector. It’s not their fault, per se, since it’s Netflix dragging their heels, but on the other hand Anker/Nebula did continuously advertise this projector as Netflix supported…

Nebula seeing this is hit and miss, I’d encourage to keep to email so it gets to the right team.

Implication is you are the first to encounter this so when you get a fix please post here so subsequent owners can find the fix.

That’s my experience too. I used to root my non-Google Pay devices but the cat’n’mouse with NetFlix DRM meant I had to unrooted on my devices which I wanted to watch NetFlix. So yes, I’ve learned to stay extremely mainstream, swim among only popular devices to keep NetFlix working.

A patched version fills me with dread. The classic problem with smart devices with their own software is you are utterly depending on the product becoming popular and the support keeps going. I’m just seeing an implicit message to avoid this product as it wasn’t tested and no working workaround and now while it’s for sale so support can only get worse.

It’s very easy to get an expensive paperweight. Of course you can plug in a mature and very popular dongle like a Chromecast and use the Cosmos as a dumb projector, that’s more likely long term successful.

In the Android space most brands provide 2 years of software updates then you’re frozen at an old Android and eventually newer apps don’t work on old Android so 3-5 years til broken. My tablet from 2 years ago has stopped getting updates so I’m expecting Netflix to stop working in the next couple of years.

The notion you can make a success of a niche Android product (Nebula premise) and it to keep working I am highly skeptical. More likely successful is a dumb projector which only has one role of projector and buy a separate highly popular dongle for safety in numbers. Fire 4K, Chromecast, etc.

1 Like

I’m having the same issue, Netflix no longer able to play any content and says it can’t access the internet, and to contact support. Other apps work fine. What is the plan to get the Cosmos approved as a device for Netflix from the main play store?

Can you guys delete netflix and install it again?

I just did that, now I got some older version of Netflix where I can’t see the side menu, the top of the UI is cut off.

The new Chromecast with Google TV supports Netflix just fine. When can we expect a fix for this?

Can you check if there is an update for the Netflix app? If that doesn’t work I’d recommend to contact support