Nebula Capusel HDMI no signal


I have used Nebula Capsule for the last few weeks and it is a great product. However, since like 4 days ago when I plug HDMI it shows as looking for signal, but it doesn’t find the hdmi. This is odd, becauise it was working before and it is not working anylonger.

I tried with different laptops and HDMI cables. Same error. I have updated all graphic drivers.

On Windows 10 it is just showing HDMI NO signal. On Ubuntu 18.04 it shows “Searching for HDMI”, then goes back to Home, then “Searching for HDMI” then Home again for at least 10 times until it loads the HDMI properly.

What could potentially be wrong?

Thank you!

Your problem is most likely a physical hardware problem with the cable not being fully seated or plugged in. Other users have reported similar problems in the past.

If I were troubleshooting the problem I would first start with the HDMI source that you know is reliable such as a DVD player Chromecast etc (you can also try the small 3 or 4 inch HDMI cable extender that comes with the Chromecast, the HDMI connector on the small extender is very streamlined & allows you to fully plug the HDMI cable into your projector.