Nebula Capsule stuck on Android No Command

I got a message to upgrade my firmware on my Capsule D4111.
When I restarted, it stayed on the Nebula screen with the 3 dots. It restarts over again and does the same thing never actually booting into the system.

I tried to recover using the only instructions available.

I tried

  1. When Capsule is powered off, press and hold “Volume+” and “Power” buttons simultaneously for about 4 seconds until Nebula screen appears. Then Android’s robot logo will appear on screen.
  2. Then, press and hold “Power” button, follow by pressing “Volume+” and the Android Recovery screen appears soon.
  3. Press “Volume-“ button to skip to “Wipe data / Factory reset” option.
  4. Press “Power” button and choose “Yes”, system will automatically jump back "

I only get an Android screen with the instruction “No command”.

Any help would be appreciated.

You just need to Press Power then Volume + again (yes, one more time), then the boot options will show, you can navigate using volume - or volume +, use power to select