Nebula Capsule reads USB, but doesn't play files

When I connect a FAT32 formatted USB to my nebula it can read it and it shows up in file manager. However, when I go to play a video (on VLC) I get the error message “The Location File cannot be played”

Any ideas?

Perhaps the space in your folder name. Are you getting the same error for all video formats?

.MP4 file format is supported and should work. I tested connecting OTG cable and played the file from a FAT32 formatted USB Stick.

Try to remove any spaces in file name as @ndalby suggested above.

Additionally, How large is the file you are trying to play?
Also try to place the file in the root folder (without any folders on the USB drive)

Spaces and long folder/file names are bad some times

I have a similar issue:
My Western Digital HD i used to copy my movies to from my Macbook Pro
The Nebula sees the HD but said- Not supported :triumph:
I didn’t know about this formatting issue when Anker said you can Connect an external hd and then watch the movies from that.
I tried using VLC but :man_shrugging:
Is there anyone that can offer me a solution like a work around perhaps Or am I screwed :woozy_face::man_shrugging: