Nebula Capsule Max - USB Not Supported

I have tried several USB Flash Drives formatted in both FAT32 and NTFS in my Capsule Max, but as soon as I plug them into the USB port, I get a “USB Not Supported”. The “test” movie I have loaded on the USB is an MP4 movie, but since I can’t get my device to recognize the USB flash drive, I can’t get to the file on the drive (via both VLC and Kodi) - the drive doesn’t show up.

At my wits end after having re-formatted several drives and plugged them in only to get the same “not supported” pop up.

What is the capacity of the USB-Sticks you used?
You could try a small one < 8GB

I have the Max and no such issues. I plugged in a 8GB and a 64G no issues

I’d challenge if actually FAT and not exFAT.

What you formatting them on? I’m on Linux and use mkfs.vfat after fdisk to make a FAT partition on DOS type partition type.


Hi all - thanks for pitching in to help me. For some reason, when I use my Windows 10 machine’s “format” drive feature, it doesn’t necessarily format my USB drive sufficiently to work in my Nebula Capsule Max (NCM). These are old drives - less than 16 gig in size and have been completely stripped of data and files (which I assume is part of the problem)

However, by dumb luck, I had the idea to try my Android mobile phone (Pixel 3a) to format the drives (using a USB-C adapter), It worked! I noticed that when I used my phone to do the formatting, it added a folder and a .DAT file to the drive. So, I suppose these missing files were the issue to begin with and Windows 10 drive formatting doesn’t do anything about that.

My NCM works fine with the old drives now, playing videos in MP4 format using the VLC and Kodi players.

I’m sure many of you are reading and saying “duh” to yourselves. In my defense, it was difficult for me to find a solution by googling and very few discussions around critical files/folders for USB drives to function properly for video storage and playback.


Good to hear you’ve managed to resolve your issue :+1:

That’s a really interesting information.
But there is nothing more to say, its Windows.
I bet sticks of any capacity can be formatted perfectly with LINUX!:wink:


There are partition types it’s probably an issue between Android and Win10.

I use Linux with supports all the formats with more control than Win10, so can understand the root fault.

The projector is based on Android so yes makes sense Android format worked when Win10 didn’t.

Windows should format that stick properly. - > fat is fat.

Of course Android is based on UNIX, same as LINUX.
I bet it could have been formatted with a Mac (UNIX-based) as well)
Conclusion : LINUX what else! :laughing:

Regarding “fdisk” many users will get fears when seeing those cryptical commands,
Remember only a few know how to read and use.
There are graphic user interfaces.

Better is to tell the users there is an simple USB-Stick-formatter.
Easy to use like this :


Partition type Vs Partition scheme.