Nebula Capsule II -Can’t connect to Nebula Connect


I’m trying to connect my projector to the Nebula Connect app but it won’t find the device…It has been connected before but for some reason it doesn’t work anymore. I need the app in order to navigate in the Netflix app as the remote control does nothing in that app.

Thank you!


Nebula connect uses Bluetooth on Smartphone… Make sure your smartphone has Bluetooth enabled and discoverable.

Once BT is enabled on Smartphone, launch the Nebula Connect App and add your Nebula Capsule II, should connect

Let us know if this helps

After trying to connect it I get this message in the apl: Please make sure your Nebula device is powered on or reboot it and try again. There’s an issue somewhere…

Delete the app and reinstall it again, hopefully that helps

I have this problem too.

I’m using an iPhone 11 Pro Max running iOS 14.0.1

Rebooting doesn’t help. Uninstalling and re-installing the app doesn’t help. Uninstalling, rebooting and re-installing doesn’t help.

Uninstalling, rebooting, resetting the Capsule II, re-installing also doesn’t work.

1 Like

I have the same problem and been searching the web for a solution. Just received my Caspule 2 and I use iPhone XR

Exact same problem for me on an iPhone 8. Both capsule and app have the latest updates. It used to work fine until maybe a few months ago.

1 Like

Same Problem here. iPhone XS Max, iOS 14.0.1.

I’m seeing multiple iPhone identical issues, looks like a software update broke it about 4-5 days ago.


They don’t particularly work weekends so don’t expect a reply for a day.

If this happened in the Android space I’d just sideload the earlier version from an APK Mirror and disable autoupdate. Don’t know how you solve these issues in the lockeddown proprietary Apple ecosystem.

1 Like

Hope you guys can find a solution for such an annoying issue

For me that got just resolve upgrading to the latest firmware 9.5.20 - and even more importantly, finally I can use the remote control again just using Bluetooth (as it used to be with the amazing capsule 1) - the fact that you needed WiFi was a massive dealbreaker outdoors…

Thanks for the update, did you have to force the upgrade or did it offer the upgrade?

Glad you got it working :+1:

No update was ever offered as far as I am concerned, you have to go to settings -> Device (…) -> About -> and then update the firmware there.

Sucks you had a bad experience with support

No actually not, support was great - just the software of the capsule 2 is a real downgrade to the old capsule - makes the whole product less usable - don’t get me started with the choice of Android TV :slight_smile: Still, a great product.

1 Like

This is a community so you should actually “get started” as others learn from you.

Yes around the spring time I did think of a smart projector and researched and more complaints about Android TV than Android, more so outside of USA where app support patchier.

I’ve formed a conclusion to avoid smart projectors altogether and separate out the projector role from the software role via an HDMI dongle. I’m effectively avoiding the whole premise of an expensive Android based projector. It’s bad enough with tablets getting support, worse still for a less popular product like a projector. And bear in mind now when the product is relatively new is when support is at is best.

The Capsule Max (Android) was £370 last week and even at £100 off RRP I still had the fear of an expensive paperweight long-term. If it were £200 I’d possibly be willing to take the risk. The Capsule II is not as expensive, but I’m not supportive of the Capsule Max, that high price… with Android TV … buyers regret big time I see coming.

If we don’t share the experience we’re not helping each other.

Capsule ll , Please ensure this device iş connected to the same wifi network as your phone

to solve the problem ;

  1. Enter device preferences
  2. Enter accessibility
  3. Make NRA Accessibility Service open

the problem will be solved

I am having the same problem as above. I use iPhone 11 Pro. Cannot connect using Nebula Connect app to Capsule II. Tried rebooting as requested, software in Capsule shown as up to date, NRAccessibilityService automatically switches off when I exit the menu. Tried reinstalling app. None of the e above works. Can someone help?


Try add new device on Nebula app and then choose capsule II. Mine was originally connected through WiFi but it no longer works after firmware update. I just tried to add a new device and now it was connected through Bluetooth.