Nebula capsule 2 wifi problem

I have problems with the wifi of my nebula capsule 2, it conect to the wifi network but when i open an app it says that is not connected to the internet.

1 Like

I don’t know this device, but I think it’s a settings problem.

Other users are happy even after pulling their hairs due to problems :grin:

@ivan.gutierrez.garat suggest you contact Nebula support -

Also you may visit them in this page

There is live chat option and phone contact. Have your purchase details and product serial handy.

1 Like

I’m having similar issues regarding the wifi connections. It seems once the contents loads enough, the wifi issues lessen. I’m going to be resetting the wifi connection tonight to see if that helps.

1 Like

I just reset the router, and try with a different router and the problem is the same. I think its a hardware problem, the wifi adapter.

1 Like

@AnkerTechnical @AnkerOfficial - Is there an option for connecting Ethernet to the Nebula Capsule II like the ones Fire TV sticks or Chromecasts have? Any compatible Ethernet adapter ?

I just noticed an issue I’m having. I had to skew the screen to fit on a wall, but now I can’t get the picture to correct itself. It autofocuses, it adjust some of the size, but it won’t put the picture into a perfect rectangle. It may have readjusted itself, but the OS does seem to need an update to fix a few bugs. All in all, still a really solid machine!

Do you still have the problem with WiFi? What do you to solve the problem?

I have’t used it much in the last few days, so I have not attempted to solve the problem yet. I may just end up doing a factory reset to see if that helps at all.

The problem its the same after 8 factory resets, in my case i think its the WiFi adapter.

I was also wondering if some of the issues could be fix with a simple firmware update. I’m sure as time passes and updates start rolling out, it’ll get more and more solid. It’s already a pretty solid piece of tech!

Hi @ivan.gutierrez.garat and @TheCharneco,

Sorry to hear you’re experiencing wifi problem when using capsule II. Please take a short video to show us the problem and send it to, our customer support team will try the best to solve it to you.

I was using it briefly last night. Watched about 15 minutes of The Big Bang Theory and had no issues. Then I noticed there was a firmware update, so I spent the next hour trying to get the update to download and then actually update. It finally did after the third try. I’ll be using it some more this week and will see if the problem continues. If it does, I’ll get it on video and will contact support. :slight_smile:

Thanks so much!

1 Like

I recently did the firmware update, initially seemed fine, now though I’ve been getting a good connection to the WiFi when I check the settings but no videos will play because ‘there was a problem with the network’. All my other devices are fine and I reset both the router and the Capsule 2

1 Like

Hi has anyone else Nebula Capsule 2 just stopped working? Mines will not charge back up. I used the provided power cord but it’s not charging the device back up. I even used the power cord on my cell phone just to test and see if the power bank and cord was working. It was charging my phone up. Now I was watching the device and it wasn’t plugged into the wall. The battery did drain after about 2.5 hours and when I notice the res light flashing I went to plug it into the wall but device switch off. I didnt think anything of because I was just going to plug it into the wall. When I attached the power cord nothing happend and it’s been this way since Friday. I press the power button nothing happens. If I press and hold the power button it will flash read about 5 times or so but I still dont get a response my from my device. Can anyone help with this problem? I like my Nebula Capsule 2 I just can’t get it to power back on or charge it up again.

To verify the issue further, please take a short video and send it to, our customer support team will try the best to resolve the issue for you.

Hey guys, I had the issue I am connected to Wi-fi but it said no internet.
What worked for me:
In my router “TP-Link” settings DHCP ->Address Reservation-> and set the MAC address of my Nebula II to the IP address that showed up on the Nebula.

Wish I help somebody and have a great day =)

1 Like

try charging it on your PC USB port, it worked with mine

I had the same issue when I installed a new netgear orbi router. I had previously had an asus which it worked fine on. I found that the new router was seeing the nebula projector as an android phone. I logged into the router and was able to change the setting on the nebula connection which was listed as “android…” and changed it to Entertainment(Generic) and that resolved the issue. In addition if anyone ever has the power issue where the unit will not turn on despite being fully charged. I left mine on the charger for 2 days and then it somehow worked again. That was about 8 months ago and haven’t seen the issue since.

1 Like