Nebula App Connecting Issue with Capsule II

Hi everyone,

I’ve some issues with the nebulae capsule II after the latest update (Version - V0.0.19.20190426). I am not able to connect to the nebula connect app

I tried everything

  1. Restart the Nebula Capsule II multiple times
  2. Used another wifi (both capsule and app connected to same wifi)
  3. Uninstall & Reinstall app multiple times

I am always getting below error message
“Make sure your device and app connected to the same wifi network”

Its really frustrating !!! :-:angry: :angry:

Anyone has similar issues or -preferably- the Solution?


Yes, the Android app (on Samsung Galaxy S10e) stopped working after the latest update for me, too. It worked literally the moment before the update.

The iOS app (on iPad Pro 2017) is unusable: it connects but the mouse cursor on screen moves incredibly slowly and with a huge lag, you can’t really do anything through it. Haven’t used the iOs app too often, though, so not sure if this is related and when it broke.

At least I have a separate Chromecast, so can work around Netflix being even less usable on Nebula than usual.

So, after removing the projector for the app and re-adding it back, it is now working.