Nebula 2 - so frustrated I want to cry

Hi all. I was so excited to get my Nebula 2. I loved the original Nebula and never had any problems. The interface on the Nebula 2 is incredibly frustrating, and I wanted to see if anyone else has these issues (or solutions to them). For starters, I am using it with an Iphone to control it (don’t have android phones). Also, while I am very technical (work in information security), I am an Android and Google Play novice. I am frustrated to the point of tears over the fact that this Nebula 2 seems very half-baked. The hardware is amazing and solid, but the firmware and software are full of holes (unless I am just that dumb that I can’t figure it out) So, here goes:

  1. No netflix. So I installed a file explorer and somehow navigated to the APK folder, where I found the holy grail, a Netflix APK (still don’t know what APK is, but I guess an install file???). Anyway, I installed it but now the only way for me to launch Netflix is to go back to File Explorer, go to the APK folder, and reload Netflix, and then choose “open” after it finishes reinstalling. This seems super cumbersome. Isn’t there a way to just have Netflix be listed among my apps? Or at the very least, not have to reinstall it every time I want to use it?

  2. No facebook - I found something called “facebook watch” which blasted full-volume videos at me the moment I opened it, but where is regular facebook?

  3. No Amazon Prime Video???

  4. No native Apple Airplay??? What??? Isn’t that a given in today’s 2-state solution world of Iphone and Android? I found a knock-off app, but still…

  5. No Chrome browser? Or any browser? How is that possible?

  6. So since there is no browser, I can’t simply browse to a downloadable file and well… download it? It seems from other posts that I have to also be a Linux expert to do something (not sure what exactly) on a Linux box, put whatever-it-is on a memory stick, and then do something-else-not-sure-what to install on the Nebula 2. Am I getting this right? There is no emoji to express what I am feeling here… thank goodness I speak yiddish so I can find some choice expressions that will do nicely.

  7. How the heck do I delete an app that I realized I don’t want???

  8. Autofocus - sometimes works, sometimes does not. Sometimes it re-focuses when you move the projector closer or farther away. Sometimes it doesn’t and you have to hold the remote button for 2 seconds to force it to refocus (no problem there). The phone app doesn’t seem to have the ability to force autofocus. However, sometimes it drifts out of focus even though you didn’t move it (or even touch it). When I tested it out using my large pull-down screen (from about 5-6 feet away), it would not lock in on the focus, it kept autofocusing but ending with a blurry image each time. So, I went into settings to try to use manual focus - except that the manual focus option simply engages the autofocus, instead of giving you a manual focus slider. Earlier today when I was testing the settings, it gave me a manual slider. I exhausted the battery, recharged it, and when I tried playing around with it again, I selected “off” for autofocus, and then selected the manual focus option… but “manual focus” now only causes it to try to autofocus, rather than giving the manual slider. Ugh. That nice, simple, manual focus wheel on the old Nebula is looking pretty good right now.

  9. The Capsule Control app, which worked great for the original Nebula, is totally wonky. It makes the Capsule on-screen keyboard pop up as if I am using the remote, when I am actually using the phone app. Then the stuff I type on the iphone keyboard won’t show up on the Capsule screen unless I switch from Mouse to Controller and then back to Mouse… THEN (and ONLY then) will the iPhone keyboard actually interact with the Capsule and my typing shows up. The Capsule on-screen keyboard keeps popping up when I select something that requires typing, regardless of whether my iphone app is in Mouse mode or Controller mode… and it won’t go away unless I select Controller and click elsewhere on the screen. If I want to type using my phone keyboard, I have to do the above routine (switch back and forth from Mouse to Controller and back to Mouse) until the Capsule recognizes my typing from my phone. During the whole time that I am typing on my phone keyboard through the app, the Capsule on-screen keyboard is being displayed, blocking half the display, because for some reason it still thinks I am using the remote control. You would think that something basic, like automatically sensing if you are using the remote control (bluetooth or infrared?) or a phone app (through wifi) would be a no-brainer, and that the on-screen keyboard would adjust accordingly, but hey… what do I know? This whole Capsule to phone app interface is half-baked and not ready for prime time.

Bottom line - I spent a lot of money for (what I thought was) an upgrade from the original Capsule (which I absolutely loved). I agree that the hardware is a significant upgrade - picture quality, brightness, battery, sound… are all amazing. But none of that matters if the darn thing is unusable due to lack of apps and a buggy interface. A consumer should not have to be an Android expert to make this thing work. It should work out of the box, with major apps to support it. Also, a consumer should not be forced to take risks with unapproved apps and grey-market, non-verified downloads from unknown sources, “side-loading”, etc… just to get basic functionality that should have been built in from the start. I have been excited to get this since I bought it for myself on Kickstarter as a holiday gift to myself 6 months ago. I anticipated that if I was in love with the original Capsule, I’d be positively infatuated with this upgrade. Sadly, this is not the case. Anker needs to quickly get the firmware and apps up to speed to do this device justice. The expectations they have for their consumers (to be so tech savvy that they will be able to navigate the bowels of the Android operating system) is completely inappropriate for an end-user consumer toy like this. Anker - I really want to love you again… what do you have to say?


I haven’t used the nebula 2 very much as it only arrived today but the projector is now stuck on the shortest focal distance (like 10cm or something) it triggered and auto focus whilst I was moving it a little and it seems to have stuck the lens. I can’t force it to refocus and now it’s completely unusable :frowning:

I strongly suggest reaching out to support via email. You may not get a response from them here.

I did. Actually, I copied this entire post into an email and sent it to both support emails ( and I have not received a response.

Addedum: I did a factory reset and also ensured that the firmware is the latest version (it was). These steps did not resolve any of the issues.

I’m waiting for a response from them myself. I’ve literally got a broken machine :frowning: if it was just bugs, I can work around but I can’t see a thing

1 Like

7 : you can see all the installed apps in the settings. I think it was either in “apps” or “storage” and when you choose an app, you can uninstall it there.

8 : on the remote control, you can long press the button HDMI/ATV to trigger the auto focus.

Wow I’ve seen so many bad reviews of nebula II…what’s going on?

I’ve only read 3 so far, including my own :smiley:

And it was a different problem every time. So personally I wouldn’t agree…

Well then good for you :ok_hand:

I kmow how to get it to autofocus. The autofocus wasn’t working. I have now updated the firmware (at Anker’s suggestion), and the autofocus works better initially, but then once I start playing the movie, it immediately drifts out of focus to the point where it is unwatchable. Also, the manual focus doesn’t work - it merely tries to autofocus instead of giving a manual control.

1 Like

I could not agree more. Nebula Capsule I is a hazzle-free plug-and-play product. Capsule 2 is a total nightmare. I did get responses from Anker support to side-load Prime and Netflix, but still loads of things to not work properly as the remote APP on IOS (I wonder how you found out about switching from mouse to remote for typing to work…?).
Also I have no clue how to download a video on the 4,4GB internat memory…
The Google TV interface is the worst product I have see from Google ever. I am a Google fan…


First we have to decide - do we have a problem or not? some owners with issues are saying there is no issue :joy:

It seems to me the issue is iOS users trying to navigate Android

Tank… Thanks for your brilliant insight, but… ummm, no. Read the issues I typed above. The darn machine won’t focus properly - that’s not an iOS versus Android issue. Neither is the fact that there was no way to launch Netflix until they added a special “Netflix” button to the phone app, as a workaround (there is still no way to launch Netflix from the remote). The fact that there is no Amazon Prime app in the Google Play store, and you must contact Nebula support for a file to side-load, is also not an iOS issue. There are numerous functions that one finds out from emailing tech support, which are not documented anywhere. The iOS phone app keyboard does not work properly, which support has acknowledged but not yet fixed. Some functions are ONLY available through the physical remote (i.e. manual focus and forced autofocus), while others are ONLY available through the app (i.e. launching Netflix). I could go on and on… but you get the point. So, instead of turning this into yet another social-media-us-versus-them pissing contest, why not post something helpful, or simply stay quiet?

I installed Kodi and can access Netflix, Amazon Prime, … directly from that.

The occasional lost focus issue is definitely annoying but support told me they’re working on firmware update for the optics engine. I have the impression that it mostly loses focus when the audio is playing very loud with a lot of activity going on, as if the vibrations of the sound throws it off.


  1. So they added a netflix button to the Nebula control app… but you still can’t access Netflix from the regular screen using the physical remote. Also, Netflix doesn’t load your "dashboard’ or whatever they call it… the top section that shows what you are currently watching. So you have to navigate to your show/movie each time using the search function.
  2. You can’t turn the Nebula 2 on/off using the app… there is simply no power button (there IS a power button when the app is connected to the original Nebula).
  3. They released a firmware update (on May 28th) to address the focusing problems… but when I attempted to update, it downloaded and then failed. Awaiting an answer from Nebula tech support.
  4. Between the app keyboard issues, lack of power button in the app, and lack of Netflix access using the physical remote, a user has to juggle between the physical remote and the phone app to navigate the Nebula 2. Really, this is ridiculous.
  5. New discovery - I tried to charge the Nebula 2 using a standard USB-c cord plugged into a wall multi-port charger box. Nope. A message popped on the screen saying “please use the supplied charger”. Interesting. Wonder what the power requirements are.
  6. Side note - I actually turned on both my original Nebula and my Nebula 2 side by side. I saw no noticable difference in brightness. They were aimed at a real movie screen, from the same distance away. I projected the images side-by-side. I know the specs say that the old one was 100 lumens an the new one is 200 lumens, but I don’t see “double” brightness. In fact, I don’t see any perceptable difference (but admittedly, I am not measuring with scientific equipment).
1 Like

Seems to me that everyone is having problems with Capsule 2? I will just wait till my Capsule 1 to burn out before I switch then. Hopefully by that time Anker fixed all the issues that everyone has and I get to use the finalized version :smile:

UPDATE 6/4/19: More interactions with Nebula support - they tell me to upgrade the firmware with their latest update. I try several times, and it fails each time. I advise tech support of this. They answer, “After I checked with our product team, we’re going to upgrade our system and it will be completed at the end of the month. After that, there won’t be any problems when updating. I will keep you posted.” So… I basically have a $300 bluetooth speaker with half-baked projector features that can’t even be fully utilized because of the focusing issues… and the Nebula folks can’t even deliver system updates reliably - they need an entire month to “fix” their system that lets customers download system updates. I think this company is being run by 12 year olds. I should offer them a project manager from my PMO to help.

1 Like

Hi - Has there been any fix since these posts? Mine was working - as of yesterday autofocus simply does not work at all, nor does manual. If I have it an inch from a wall it is readable to update, but once it has downloaded the update it does not install it. It also makes an annoying buzzing sound while on. So, I basically - as above - have an expensive speaker…
Not impressed…