My bluetooth keyboard turns on, but nothing happens when I press Fn + Z

I have an Anker A7726 Bluetooth keyboard. I primarily use it with my Apple TV at home, and it works perfectly well with no connection problems. I’m trying to connect it to my Mac Pro at work, and with “discover” enabled on the computer, I try to press the Fn + Z (bluetooth) keys, but the indicative flashing blue light doesn’t happen to let me know it has entered pairing mode, and nothing happens on the computer. I’ve tried pressing them together quickly, and holding them together for several seconds. The keyboard powers on, with a brief blue light at the top blinking once as it normally does, but nothing happens to make it seem like it’s entering pairing mode. What am I doing wrong?

Sounds likeyou’ve tried most combinations. Have you tried pressing the fn button first before pressing and holding the z key for 3-4 seconds? I’ve found in the past this was the most reliable way for pair mode.

Yep. Installed brand new AAA batteries too. I just tried holding down Fn, then holding the Z key for several seconds. Waiting even longer, nothing happens on the mac, and the blue light doesn’t flicker. Is it somehow wishing it would connect to the Apple TV and not even wanting to try to pair?

If you are using the keyboard at work (so essentially more than 15m away from your Apple TV), I would expect the keyboard to revert to pairing mode again (which is default behaviour for most BT devices). You might be best dropping an email with your issue and troubleshooting steps taken for further assistance but be aware that response times will be slower this week due to their New Year holidays.

Did you ever find a fix for this? I’m having the same issue!

i know im 2 years too late but someone else posted a very similar question (im having the exact same issue). my keyboard just randomly decided to stop working on my computer, i didnt try to move the keyboard or connect it else where nothing i literally just woke up and it wasnt working anymore. according to anker official support it means its faulty and they just stop working sometimes. if its been more than 18months then warranty doesnt cover and theres nothing they can do about it anymore. sucks a whole lot but i guess we’re all stuck now

I have similar situation like you too, randomly stop working and when I tried to pair it won’t work either!