Model Zero+ Connectivity Issues


I have a Model Zero+ for a few weeks. While it worked fine in the beginning, for a week is behaving weirdly:

  • First symptom: The Model Zero+ is in a group with a Sony S50G and a Google Home Mini. Suddenly, music commands to the group were executed only on the other two speakers. Also, when playing a playlist, the speaker disconnected after one track

  • Second and current issue: I have tried a complete reset (both from back button and microphone), shut on/off, router reset, deleting from home, deleting the home. Everything that can be done. Now, the speaker appears on the Home app (iOS) but always with a link to “Link Account” or offline.

Link account - this triggers a firmware update but I have the suspicion that it cannot be completed. Current firmware is 36 and cast firmware 1.32.129357

Also things are very weird: time/weather/tell me a joke commands work (so connection to internet is established). Play Music/Give the news result in an error.

I suspect that this is a faulty firmware but I have run out of ideas on what to do

1 Like

I think there are not many forumners who own a ZERO+.

So it may be the best you contact the support with a video
talking about your issues.

I hope they can help you, but keep in mind there are vacations at the moment, as far I know.

Well, glad to be one of the first beta testers :))
I have contacted support and they offered a replacement. The problem is that I’m in Europe and the first one already cost me an extra 100USD for shipping. Sending the faulty unit and receiving a new one would add 200 more and that’s a little bit too much for a speaker.
Just hoping that a team member or somebody with a good idea drop by this thread :slight_smile:

You are a “lucky man”! :wink:

As far I know, no one here from the community got such a ZERO + for beta testing.
Only a few got a ZERO from a testing contest.

Are you trying to use the Google home app or the Soundcore app? If you use the Soundcore app you can do a firmware update on the speaker itself via the Soundcore app and see if that helps any. I myself only have the Zero not the plus so I’m just guessing here. But have you also uninstalled the home app, restart your phone and then reinstall it?

Did you get this as a beta test or did you buy it? I never heard of someone paying for an item that they beta tested

1 Like

Beta testing was a joke regarding the quality of the product.
In the beginning I could use the Soundcore app but I haven’t seen any firmware options. Now, in the current state, I cannot use the soundcore app as this requires the speaker to be added on Google Home app.
Yep, unistalled after deleting all the settings restart phone after

Have you tried to let home do the firmware update on it’s end?

each time I let it finish and there is no error message. But after each reset I have to do it again.
Out of curiosity, I just did it again and stopped it before finishing. The firmware is the same as the one mentioned. This makes me believe that the firmware cannot be udpated

When you said you reset the speaker, how are you doing it. And how long are you holding the button

There are 2 possible ways:

  • in the back the right side hole pushed with a pen

  • hold the mic apx 10 seconds. When the reset is complete, a line of red lights appears and the units resets

Tried both options. Multiple times

Once you get it set in home, open the Soundcore app and look for a firmware update

That’s the issue. I can’t get in home anymore. I set it up, performs the software update, responds to basic commands (time/weather/jokes/set an alarm) but for getting news and music gives an error. When I open the Soundcore app in this state it gives me a “Device not found set it up with Google Home app”.
And yes, we are under the same network

Sorry. I can’t help. I don’t have this speaker. I don’t know that a lot of people do yet because I believe it’s fairly new.

My only advice then is to reach out to they will best be able to help and assist you. They may even be able to send you a firmware file that you can install via your computer like they have for the flares.

1 Like

Thanks, I have emailed the case to the service, maybe I get a better response than support :slight_smile:
Keep you posted!

It is Chinese New year so they may not get back to you right away.

I’ve been having the same issues mentioned here, although I’ve been on firmware 37.

After reseting the device the first time (speaker wasn’t casting to Spotify), it was no longer able to register with Google Home on Android. A Reddit search led me to learn that borrowing someone’s iPhone may help, which it did. At least it was no longer bricked and could access the internet.

For music, I get “sorry something went wrong. Give it another try.” Spotify Connect no longer sees it. Moreover, the Soundcore app doesn’t recognize the speaker anymore.

This is definitely a firmware issue, and I hope they can update it soon. My phone and the speaker are, naturally, on the same network. Fortunately Bluetooth still works, which is better than nothing for now, but there are some serious issues going on.

I’m a beta tester and received it back in early October 2018.

System firmware version: 37
Cast firmware version: 1.32.129357

1 Like

Thanks a lot for sharing your experience. At least I’m not crazy :slight_smile:
Is disappointing to know that firmware 37 has the same behavior, but I suspect that the issue is with the casting firmware and there we have the same version.
Support has declared the unit damaged and no effort to fix it but I think that’s nearly impossible to say that the problem is with a hardware casting component

Well that means that it’s likely the all Model Zero+'s are damaged, especially once reset, as they cannot properly connect to the Google Home app properly. With Android, I receive a Chromecast error.

I’ll try reseting it again in a few days and will re-setup with my SO’s iPhone.

1 Like