Mars II Shutdown Problem (Netflix?)

Bought a Mars II last July, been very happy with it. This week it has started abruptly powering down after ~15 min of streaming Netflix. Restart by closing/opening the shutter, and it runs for another ~15m then shuts down again. This is while plugged in, and according to both the LED and onscreen battery indicators, fully charged. Mounted on a tripod, nothing to block vents or trigger overheating. Up-to-date firmware and Netflix app versions. Need to test with Plex for comparison, but anyone else experienced similar issue?

Have you contacted customer support?

I have exact the same issue on my Nebula Capsule!
It shuts down to powersave mode after 15 Minutes automatically. This happens with Netflix. I have to test the issue with some other apps these days.

Have you tried an uninstall / re-install of the effected apps and/or a factory reset to see if this resolves?

As @kumar.sachin has mentioned reaching out to with your issues and troubleshooting steps taken would be a good idea as they might be able to resolve with a firmware update…


I will try this tonight and post the result here. Thank you!

I watched Plex instead of Netflix for ~45m last night with no issues, so I’m guessing it’s a problem with the latest version of the Netflix app.

1 Like

Tried watching Netflix again last night, and ~15m in it was right back to the shutdown problem after working perfectly with Plex the night before, so I’m pretty sure it is specific to Netflix.

Hi, I recently have a problem and my capsule will not open Netflix. Everytime I go to open it says “unexpectedly closed” or “stopped working” I’ve reset the whole device to factory and update and re-installed and still nothing…

Is anyone else having this issue or knows how to fix?




i bought my MARS 2 3 days ago, and have same issue , contacted live support and we found it netflix update causing it to shutdown based on auto sleep intervals. clearing cach of app fixed it for me , but lasted 40min then i shut down again.

Disable auto sleep mode, or set it to the maximum limit, see if you can get more watching time.

I believe the issue is the system not recognizing that there’s activity happening, even though the app is running.

1 Like

Already tried the above, setting auto sleep to 30 minutes, and the device keeps rebooting when running Netflix. Also noticed it will restart occasionally when inserting the charger mid reboot cycle. Weirdest thing…

Any help is appreciated!

Check for an update to the Netflix app - that’s what eventually resolved it for me.

Has anyone fixed this??? I am having the same problem… my mars pro 2 shuts down then gets stuck in a boot loop

Having the same problem, even after factory reset and connected to power