Lights Blinking in sequence and won't charge phone

So I plugged my PowerCore 10000 in last night and took my phone charging cable out of it to charge my phone in a different outlet. When I tried to use the battery today, all four LEDs went on, indicating that the battery was fully charged, but when I put my cable back in, the LEDs instead light up 1, then 2, then 3, then 4, and my phone doesn’t charge. This happened with multiple charging wires and with each, all four LEDs come on in that sequence. Could a pin in the USB port be misaligned?

Have you tried charging any other device than the smartphone? May be a BT headset…

Either the PowerCore 10000 might have bad USB leads or this may be with the phone charging port as well.

Try charging a different phone or a separate device such as headset.

If this is a newly purchased or purchased within the last 1 year, you may contact

Does the charger you’re using, have trickle charge?

If not, it may be too strong a charge, and giving a false positive (saying it’s charged when it’s not).

Use a smaller charger or one that does trickle charge, and try again, or try a different lead.

I know, it what we always say, but more often than not, the problem is not the powerbank, rather the cable or power source.

You should probably send Anker an email letting you know about your issues

I have the exact same issue with a Powercore 10000. Has anyone been able to resolve this?