Liberty Neo not working as Headset

Hi, I’ve paired my Liberty Neo with a Windows 10 HP ZBook. The earbuds show as both headphones and a headset. Using as headphones I can hear sound but as a headset I can neither hear sound or use the mic.

I have tried re-setting the earbuds, removing then re-pairing them. I have tried installing the latest drivers for the ZBook, re-setting, removing and re-pairing. Still no joy.

I have tried the same tests with a different laptop (Lenovo) and still have the same issue. This leads me to believe the issue is either with the earbuds or something I am doing wrong when connecting them as a new Bluetooth device.

On the reset I press and hold the buttons on the buds until a red light appears then pop them back in the case. I take the right bud out of the case followed by the left, the right flashes fast the left flashes slow. When they connect they show as connected for audio and voice.

Any help to get the buds working as a headset is gratefully received.

We are sorry to hear your Soundcore Liberty Neo headphones are not working properly.

According to the information you described, the issue you are experiencing is very unusual, it seems that the issue was caused by the compatibility.

For more detailed assistance, we appreciate you could directly contact us at by detailing your order number and the problem you come across, we will check it with the technicial support team and will reply you within 24 hours.

Any solution to this yet? Im on a Lenovo P71 and have the same exact issue with skipping audio while watching YouTube videos and wont work as a headset in my Microsoft Teams calls. Tried resetting the earbuds and still persists. I’ve also got airpods and no issues in the same setup so it seems localised to the Anker earbuds. What should I do to fix this?

Hey Bennett Baker,

In short yes the very helpful Anker team got me to troubleshoot some issues then swapped my ear buds out.

When I first connected the new buds I checked the audio settings in zoom and they didn’t work, but the headset bar kept flicking up and down. I rebooted the machine and boom they work a treat.

I do still have one issue whereby if my laptop hibernates or I manually disconnect my ear buds, I have to reconnect them and reboot the laptop. This appears to be an issue with the laptop though and is most likely due to a group policy rolled out by my employer as I do not have issues on other laptops.

So I just shutdown whilst the buds are connected and make sure the buds are out of the case and ready to go before I boot up in the morning.

1 Like